Happy New Year!

I met the error show on storm's web ui:

Topology spouts lag error: Offset lags for kafka not supported for older
versions.Please update kafka spout to latest version.

It say update the kafka spout , but which module I should update?

*There more info:*
--------------------------------------------
*Info1*. softerwares version:

The softerwares version runing normally (could alert the message on web):

jdk1.8.0_151
scala-2.11.8
apache-maven-3.5.2
*apache-storm-0.9.7*
hadoop-2.7.4
hbase-0.98.8-hadoop2
zookeeper-3.4.10
*kafka_2.11-0.10.1.1*
logstash-2.4.1
eagle-0.5.0

The softerwares version could send message to the storm's topology:
there the different:

*   apache-storm-1.1.1   kafka_2.11-1.0.0*

--------------------------------------------

*Info2*. the error show on storm Web UI

Topology spouts lag error:

Id    Type Message ingest         KAFKA               *Offset lags for
kafka not supported for older versions. Please update kafka spout to latest
version.*

[image: 内嵌图片 1]

Thanks,
Wuqize

2017-12-17 21:35 GMT+08:00 Hao Chen <[EMAIL PROTECTED]>:
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB