Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # dev >> hbase-0.92.0 up in maven repository


Copy link to this message
-
Re: hbase-0.92.0 up in maven repository
Hi,

Right. The problem was that my local ivy cache contained the hbase parent
which does not know about the tests jar. So, if you have cached the 0.92
poms between 03/02 and 03/06, you have to delete that entry from your
cache. Still not seeing the tests jars in search.maven.org bothers me a
little, but it think it is best to focus on releasing 0.92.1 instead.

Thanks Arvind,
Enis

On Thu, Mar 8, 2012 at 2:13 PM, Arvind Prabhakar <[EMAIL PROTECTED]>wrote:

> On Thu, Mar 8, 2012 at 1:55 PM, Enis Söztutar <[EMAIL PROTECTED]> wrote:
>
> > Hi,
> >
> > Sorry, but I have bad news. I guess pushing the tests artifact did not do
> > the trick. Although we can see that
> > http://repo1.maven.org/maven2/org/apache/hbase/hbase/0.92.0/ is
> populated
> > by the tests jar, I don't see it in
> > http://search.maven.org/#browse|1617628244. Also, in Sqoop and Hive, the
> > configuration :
> >
> >   <dependency org="org.apache.hbase" name="hbase"
> >      rev="${hbase.version}" conf="hbase->default">
> >      <artifact name="hbase" type="jar"/>
> >      <artifact name="hbase" type="test-jar" ext="jar"
> > m:classifier="tests"/>
> >
> > does not fetch the actual tests jar but fetches the normal jar. So sqoop
> > out of the box does not compile.
> >
>
> I am not sure if this is true. Please see [1] for the build log from Sqoop
> builds. Here is an excerpt from the same:
>
>
> [ivy:resolve] downloading
>
> http://repo1.maven.org/maven2/org/apache/hbase/hbase/0.92.0/hbase-0.92.0-tests.jar
> ...
> [ivy:resolve] ..........................................................
> (1449kB)
>
>
>
> You can actually see the hbase-0.92.0-tests.jar file in the Ivy cache
> directory as well [2].
>
> [1]
>
> https://builds.apache.org/view/S-Z/view/Sqoop/job/Sqoop-ant-jdk-1.6/94/console
> [2]
>
> https://builds.apache.org/view/S-Z/view/Sqoop/job/Sqoop-ant-jdk-1.6/ws/build/ivy/lib/sqoop/hadoop23test/
>
> Thanks,
> Arvind
>
>
>
> >
> > Eniss-MacBook-Pro:sqoop$ md5sum
> > build/ivy/lib/sqoop/hadoop23test/hbase-0.92.0.jar
> > 6cfa1bd84e00f8050f8d5dad59789e85
> > build/ivy/lib/sqoop/hadoop23test/hbase-0.92.0.jar
> > Eniss-MacBook-Pro:sqoop$ md5sum
> > build/ivy/lib/sqoop/hadoop23test/hbase-0.92.0-tests.jar
> > 6cfa1bd84e00f8050f8d5dad59789e85
> > build/ivy/lib/sqoop/hadoop23test/hbase-0.92.0-tests.jar
> >
> > My uneducated guess would be that the parent hbase pom in maven repo was
> > not updated, so it does not know about the tests jar, which is deployed
> > later. But would be glad if anybody can shed some light.
> >
> > Thanks,
> > Enis
> >
> > On Tue, Mar 6, 2012 at 12:47 PM, Arvind Prabhakar <[EMAIL PROTECTED]
> > >wrote:
> >
> > > On Tue, Mar 6, 2012 at 12:23 PM, Stack <[EMAIL PROTECTED]> wrote:
> > >
> > > > On Tue, Mar 6, 2012 at 12:15 PM, Ioan Eugen Stan <
> > [EMAIL PROTECTED]>
> > > > wrote:
> > > > > 2012/3/6 Arvind Prabhakar <[EMAIL PROTECTED]>:
> > > > >> Thanks St.Ack. I don't see the test artifacts in [1] yet but that
> > > could
> > > > be
> > > > >> because it takes a few hours for the bits to propagate. I will
> check
> > > > again
> > > > >> later today/early tomorrow and if everything works will drop a
> note
> > > for
> > > > >> confirmation.
> > > > >>
> > > > >> [1] http://repo1.maven.org/maven2/org/apache/hbase/hbase/0.92.0/
> > > > >>
> > > > >> Thanks,
> > > > >> Arvind
> > > > >
> > > > > I saw the tests jar. Yey... more happy coders.
> > > > >
> > > >
> > >
> > > I can confirm too that the tests are now available and Sqoop is able to
> > use
> > > the correctly.
> > >
> > > Thanks,
> > > Arvind
> > >
> > >
> > > >
> > > > Sweet. Thanks for the help and the poking all.
> > > > St.Ack
> > > >
> > >
> >
>