Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo, mail # dev - MapReduceExample When Executed Displays Usage And Error Message


+
David Medinets 2013-02-09, 03:19
+
Christopher 2013-02-10, 01:04
+
David Medinets 2013-02-10, 01:40
+
Jim Klucar 2013-02-10, 01:45
+
David Medinets 2013-02-11, 03:59
+
John Vines 2013-02-11, 04:23
+
David Medinets 2013-02-11, 04:28
+
Josh Elser 2013-02-11, 10:51
+
Jim Klucar 2013-02-11, 17:35
+
John Vines 2013-02-11, 04:56
+
Keith Turner 2013-02-12, 15:43
+
Keith Turner 2013-02-12, 16:07
+
Keith Turner 2013-02-12, 18:59
+
David Medinets 2013-02-13, 02:03
+
Keith Turner 2013-02-13, 17:33
+
David Medinets 2013-02-13, 22:26
+
David Medinets 2013-02-13, 22:51
Copy link to this message
-
Re: MapReduceExample When Executed Displays Usage And Error Message
David Medinets 2013-02-13, 23:21
I am sprinkling println statements around. I noticed in
MiniAccumuloCluster.exec my HADOOP_PREFIX is null. Is that OK?

    String env = System.getenv("HADOOP_PREFIX");
    if (env != null)
      builder.environment().put("HADOOP_PREFIX", env);
    System.out.println("HADOOP_PREFIX: " + env);

On Wed, Feb 13, 2013 at 5:51 PM, David Medinets
<[EMAIL PROTECTED]> wrote:
> I add the VFS2 jar to my classpath. Now this message is displaying:
>
> Exception in thread "main" java.lang.RuntimeException: Initialize
> process returned 1
>         at org.apache.accumulo.test.MiniAccumuloCluster.start(MiniAccumuloCluster.java:326)
>         at com.codebits.accumulo.MapReduceExample.main(MapReduceExample.java:55)
>
> The code that generates this message is
>
>     Process initProcess = exec(Initialize.class, "--instance-name",
> INSTANCE_NAME, "--password", config.getRootPassword(), "--username",
> "root");
>     int ret = initProcess.waitFor();
>     if (ret != 0) {
>       throw new RuntimeException("Initialize process returned " + ret);
>     }
>
> There are no log files in the /tmp directory. Not sure what to do from
> here. I will look at the Initialize class for clues.
>
> On Wed, Feb 13, 2013 at 5:26 PM, David Medinets
> <[EMAIL PROTECTED]> wrote:
>> I am still seeing the Connection Refused message. However, inside the
>> error logs I see NoClassDefFoundError:
>> org/apache/commons/vfs2/FileSystemManager. I will start adding jars to
>> my classpath until I get a harder error to resolve :)  Will report my
>> results later.
+
Keith Turner 2013-02-13, 23:16