Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo, mail # dev - MapReduceExample When Executed Displays Usage And Error Message


+
David Medinets 2013-02-09, 03:19
+
Christopher 2013-02-10, 01:04
+
David Medinets 2013-02-10, 01:40
+
Jim Klucar 2013-02-10, 01:45
+
David Medinets 2013-02-11, 03:59
+
John Vines 2013-02-11, 04:23
+
David Medinets 2013-02-11, 04:28
+
Josh Elser 2013-02-11, 10:51
+
Jim Klucar 2013-02-11, 17:35
Copy link to this message
-
Re: MapReduceExample When Executed Displays Usage And Error Message
John Vines 2013-02-11, 04:56
Because emulating the same behavior as start-all allows us to test the
client wait behavior. I would rather see the stop behavior changed to be
more like stop-all, in that it waits for it to be fully up before shutting
down.

Sent from my phone, please pardon the typos and brevity.
On Feb 10, 2013 11:28 PM, "David Medinets" <[EMAIL PROTECTED]> wrote:

> But if people start using the MiniAccumuloCluster without knowing
> their client processing need to wait? What's the harm in letting
> start() do the waiting? Wouldn't that ensure a minimum wait time and
> consistent behavior?
>
> On Sun, Feb 10, 2013 at 11:23 PM, John Vines <[EMAIL PROTECTED]> wrote:
> > I don't think so, all of our client processes are designed to wait a bit
> > for the server to come up, and this process a similar behavior as our
> > start-all script.
> >
> > Sent from my phone, please pardon the typos and brevity.
> > On Feb 10, 2013 10:59 PM, "David Medinets" <[EMAIL PROTECTED]>
> wrote:
> >
> >> Adding a Thread.sleep(1) after the start() method does seem to
> >> consistently resolve the 'Stream Closed' issue.
> >>
> >>       MiniAccumuloCluster la = new MiniAccumuloCluster(tmpDir,
> "pass1234");
> >>       la.start();
> >>       Thread.sleep(1);
> >>
> >> Which raises a question. Should the start method wait for the
> >> processes to start before returning? Any reason I shouldn't create a
> >> jira ticket for this?
> >>
> >> On Sat, Feb 9, 2013 at 8:45 PM, Jim Klucar <[EMAIL PROTECTED]> wrote:
> >> > I wonder if it is just because you're starting and stopping so
> quickly. I
> >> > know the Tserver processes take a second to come up, perhaps put a
> sleep
> >> in
> >> > for a few seconds and see if that works.
> >> >
> >> >
> >> > On Sat, Feb 9, 2013 at 8:40 PM, David Medinets <
> [EMAIL PROTECTED]
> >> >wrote:
> >> >
> >> >> https://issues.apache.org/jira/browse/ACCUMULO-1058
> >> >>
> >> >> On Sat, Feb 9, 2013 at 8:04 PM, Christopher <[EMAIL PROTECTED]>
> >> wrote:
> >> >> > Should probably have documentation and a working example prior to
> >> 1.5.0.
> >> >> Is there already a ticket for it?
> >> >>
> >>
>
+
Keith Turner 2013-02-12, 15:43
+
Keith Turner 2013-02-12, 16:07
+
Keith Turner 2013-02-12, 18:59
+
David Medinets 2013-02-13, 02:03
+
Keith Turner 2013-02-13, 17:33
+
David Medinets 2013-02-13, 22:26
+
David Medinets 2013-02-13, 22:51
+
David Medinets 2013-02-13, 23:21
+
Keith Turner 2013-02-13, 23:16