Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka >> mail # user >> tried following kickstart, says unknown host name


Copy link to this message
-
Re: tried following kickstart, says unknown host name
It works now thanks.

On Wed, May 2, 2012 at 11:12 PM, Jun Rao <[EMAIL PROTECTED]> wrote:

> Not sure about this exception. Seems not directly related to Kafka. Did a
> google search and found the following. Does that help?
> http://www.wowza.com/forums/showthread.php?337-Malformed-URL-exception
>
> Thanls,
>
> Jun
>
> On Wed, May 2, 2012 at 7:42 PM, S Ahmed <[EMAIL PROTECTED]> wrote:
>
> > Hi Jun,
> >
> > I'm on a dedicated box, not ec2.
> > BTW, I am running everything (zookeeper and kafka) on the same server.
> > Just to recap, I'm doing everthing default as per the quickstart.
> > Zookeeper started just fine.
> > When trying to run kafka server with config/server.properties I got:
> >
> > Error: Exception thrown by the agent : java.net.MalformedURLException:
> > Local host name unknown: java.net.UnknownHostException: myhostname:
> > myhostname
> >
> > Why does it repeat the hostname in the exception?
> >
> > That's all the exception I got, is there a way to get a more detailed
> > exception, is that what you are referring to?
> >
> > On Wed, May 2, 2012 at 9:57 PM, Jun Rao <[EMAIL PROTECTED]> wrote:
> >
> > > Could you put the stack trace of the exception? Normally, you don't
> need
> > to
> > > define hostname in broker. You only need to do that if somehow the
> local
> > ip
> > > is not accessible to the clients (e.g., EC2)
> > >
> > > Thanks,
> > >
> > > Jun
> > >
> > > On Wed, May 2, 2012 at 6:06 PM, S Ahmed <[EMAIL PROTECTED]> wrote:
> > >
> > > > I downloaded 0.7, updated and packaged using sbt.
> > > >
> > > > I was able to run zooker, but when I tried running the kafka server I
> > > got:
> > > >
> > > > Error: Exception thrown by the agent :
> java.net.MalformedURLException:
> > > > Local host name unknown: java.net.UnknownHostException: myhostname:
> > > > myhostname
> > > >
> > > > (where myhostname was my host name :)  )
> > > >
> > > > Do I need to tweak the config property files or something?   I didn't
> > > touch
> > > > anything, just wanted to get it going.
> > > >
> > >
> >
>