Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # user - RegionServer unable to connect to master


Copy link to this message
-
Re: RegionServer unable to connect to master
Dhaval Shah 2014-01-29, 20:39
Do you have a firewall between the master and the slaves?

Regards,

Dhaval
________________________________
From: Fernando Iwamoto - Plannej <[EMAIL PROTECTED]>
To: [EMAIL PROTECTED]
Sent: Wednesday, 29 January 2014 3:11 PM
Subject: Re: RegionServer unable to connect to master
Iam new to HBASE too, but I had same problem long time ago and I dont
remember how i fixed, I will keep troubleshooting you...
How about zookeeper? have you uncommented the HBASE_MANAGE_ZK(something
like that) in hbase-env.sh and set to TRUE?

2014-01-29 Guang Gao <[EMAIL PROTECTED]>

> You mean the SSH key? Yes, any two nodes can ssh each other without
> password.
>
> On Wed, Jan 29, 2014 at 2:10 PM, Fernando Iwamoto - Plannej
> <[EMAIL PROTECTED]> wrote:
> > Did you tried to pass the key to the machines?
> >
> >
> > 2014-01-29 birdeeyore <[EMAIL PROTECTED]>
> >
> >> Thanks for your reply. Here's some additional info. Thanks.
> >>
> >> $ cat hbase-site.xml
> >> <configuration>
> >>   <property>
> >>     <name>hbase.cluster.distributed</name>
> >>     <value>true</value>
> >>   </property>
> >>   <property>
> >>     <name>hbase.rootdir</name>
> >>     <value>hdfs://obelix8.local:9001/hbase</value>
> >>   </property>
> >>   <property>
> >>     <name>hbase.zookeeper.quorum</name>
> >>     <value>obelix105.local,obelix106.local,obelix107.local</value>
> >>   </property>
> >>   <property>
> >>     <name>hbase.zookeeper.property.clientPort</name>
> >>     <value>2183</value>
> >>   </property>
> >>   <property>
> >>     <name>hbase.zookeeper.peerport</name>
> >>     <value>2890</value>
> >>   </property>
> >>   <property>
> >>     <name>hbase.zookeeper.leaderport</name>
> >>     <value>3890</value>
> >>   </property>
> >>   <property>
> >>     <name>hbase.zookeeper.property.dataDir</name>
> >>     <value>/ssd/hbase/hbase-0.94.16/zookeeper</value>
> >>   </property>
> >>   <property>
> >>     <name>hbase.master</name>
> >>     <value>obelix8.local:60000</value>
> >>   </property>
> >>   <property>
> >>     <name>hbase.master.info.port</name>
> >>     <value>50070</value>
> >>   </property>
> >>   <property>
> >>     <name>hbase.client.scanner.caching</name>
> >>     <value>200</value>
> >>   </property>
> >> </configuration>
> >>
> >> ==========================
> >>
> >> $ cat regionservers
> >> obelix105.local
> >> obelix106.local
> >> obelix107.local
> >> obelix108.local
> >> obelix109.local
> >> obelix110.local
> >> obelix111.local
> >> obelix112.local
> >> obelix113.local
> >> obelix114.local
> >>
> >> =========================
> >> On my master node:
> >>
> >> $ cat /etc/hosts
> >> 127.0.0.1       localhost
> >> 192.168.245.8      obelix8.local xx.yy.net      obelix8
> >>
> >> # The following lines are desirable for IPv6 capable hosts
> >> ::1     ip6-localhost ip6-loopback
> >> fe00::0 ip6-localnet
> >> ff00::0 ip6-mcastprefix
> >> ff02::1 ip6-allnodes
> >> ff02::2 ip6-allrouters
> >> 192.168.245.1   obelix.local
> >>
> >> ===============
> >>
> >> On one of my slave nodes:
> >>
> >> $ cat /etc/hosts
> >> 127.0.0.1       localhost
> >> 127.0.1.1       obelix105.local xx.yy.net    obelix105
> >>
> >> # The following lines are desirable for IPv6 capable hosts
> >> ::1     ip6-localhost ip6-loopback
> >> fe00::0 ip6-localnet
> >> ff00::0 ip6-mcastprefix
> >> ff02::1 ip6-allnodes
> >> ff02::2 ip6-allrouters
> >> 192.168.245.1   obelix.local
> >>
> >> ==========================
> >>
> >> The error of HBase 0.94.16+Hadoop 1.2.1:
> >>
> >> 2014-01-29 12:58:30,922 INFO
> >> org.apache.hadoop.hbase.regionserver.HRegionServer: Attempting connect
> >> to Master server at obelix8.local,60000,1391018303918
> >> 2014-01-29 12:58:40,960 WARN
> >> org.apache.hadoop.hbase.regionserver.HRegionServer: Unable to connect
> >> to master. Retrying. Error was:
> >> java.net.SocketException: Invalid argument
> >>         at sun.nio.ch.Net.connect(Native Method)
> >>         at
> sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:532)