tsuna 2014-01-27, 02:37
Nicolas Liochon 2014-01-27, 09:03
tsuna 2014-01-27, 16:36
So is the suggestion to just add the other signature to hbase's version?
We recently ran into another problem due to this ZeroCopy class --
shouldn't it really be pushed into protobuf, or pulled out as a separate
jar of some sort. We ran into into class path/class loader problems with
it because if subclasses a com.google.protobuf class (out of a package).
On Mon, Jan 27, 2014 at 8:35 AM, tsuna <[EMAIL PROTECTED]> wrote:
> On Mon, Jan 27, 2014 at 1:02 AM, Nicolas Liochon <[EMAIL PROTECTED]>
> > Should we not rename ZeroCopyLiteralByteString to something like
> > HBasePrivateZeroCopyLiteralByteString to be sure that we won't have name
> > conflicts in the future?
> I don't mind keeping the same name as long as we agree on the API.
> I don't expect this class to change much if at all anyway. It's just
> really unfortunate that this method was changed, what's more with a
> signature that renders it unusable.
> Benoit "tsuna" Sigoure
// Jonathan Hsieh (shay)
// HBase Tech Lead, Software Engineer, Cloudera
// [EMAIL PROTECTED] // @jmhsieh
Stack 2014-01-27, 18:05
tsuna 2014-01-27, 18:07
Nicolas Liochon 2014-01-28, 17:13
Andrew Purtell 2014-01-27, 18:21