Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> Unable to see old tables after migrating from 0.94 to 0.98


Copy link to this message
-
Re: Unable to see old tables after migrating from 0.94 to 0.98
Just reporting back on mailing list that i was able to fix the issue by a
lot of manual work. This problem happened because we forgot to run "upgrade
-execute" after installing hbase0.98 and before starting 0.98.
If you dont run "upgrade -execute" then user gets and error regarding
"hbase.version". I deleted that file and then HBase came up. But since, i
deleted hbase.versions file so HBase didnt do any migration of my 0.94 data.

Here is the high level stuff that i did to fix this issue(NOTE: these steps
may vary as per cluster setup):
In ZK i did following stuff:
Deleted all znodes under /hbase/table
Recursively Deleted /hbase/table-lock znode
delete /hbase/meta-region-server
delete /hbase/region-in-transition
delete /hbase/balancer
rmr /hbase/namespace
rmr /hbase/replication
rmr /hbase/recovering-regions
rmr /hbase/splitWAL

In HDFS:
I removed /hbase/data directory and moved around some other related
directory.
Updated the hbase.version file to 0.94  version file.

Then i ran "upgrade -execute" and it ran successfully. Started the cluster
and i was able to see all the tables along with their data.
Thanks Stack for your help.

~Anil
On Mon, Jul 28, 2014 at 11:01 PM, anil gupta <[EMAIL PROTECTED]> wrote:
Thanks & Regards,
Anil Gupta