Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
MapReduce >> mail # user >> Redirects from namenode to datanode not working


Copy link to this message
-
Re: Redirects from namenode to datanode not working
Hey Visioner,
Can you show what's in your slaves file?
On Thu, Oct 25, 2012 at 5:44 AM, Visioner Sadak <[EMAIL PROTECTED]>wrote:

> any hints friends will i have to try this with a cluster set up?? with
> datanode installed on a diffrnt ip address
>
>
> On Tue, Oct 23, 2012 at 12:34 PM, Visioner Sadak <[EMAIL PROTECTED]
> > wrote:
>
>> my config files already have ips instead of localhost.....yes if i copy
>> paste ip in address bar it wrks ....is there any other place where ip has
>> to be mentioned like etc/hosts in linux....
>>
>>
>> On Tue, Oct 23, 2012 at 12:11 PM, Georgy Gryaznov <
>> [EMAIL PROTECTED]> wrote:
>>
>>> Hey Visioner.
>>>
>>> I think the problem here is that your config files are pointing at
>>> your localhost as the IP for the datanode/tasktracker. If you
>>> copy-paste the external IP for the box into the address bar, does it
>>> work?
>>>
>>> Thanks,
>>> Georgy
>>>
>>> On Thu, Oct 18, 2012 at 11:27 PM, Visioner Sadak
>>> <[EMAIL PROTECTED]> wrote:
>>> > Hello friends,
>>> >                      I m runnning hadoop in psuedo distr mode at a
>>> remote
>>> > linux ip ,Thru the namenode WEB UI i m able to access the directory
>>> > structure(thru data node) by clicking on browse the directory button
>>> but
>>> > when i click on live nodes i am able to see my datanode at localhost
>>> when i
>>> > click on tht it redirects my browser to localhost instead of my remote
>>> linux
>>> > box ip and i cant see the page....any hints on whts happening is it
>>> becoz my
>>> > datanode and namenode on same ip.....
>>> >
>>> >
>>>
>>
>>
>