Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # user >> RPM fun...have OpenJDK 1.7 installed...Accumulo rpm wants "jre"


Copy link to this message
-
Re: RPM fun...have OpenJDK 1.7 installed...Accumulo rpm wants "jre"
Unfortunately, the OpenJDK packaging for CentOS changed their provided
virtual packages to have a 7 in them for >= 1.7.0, as in:
jre7, java7, java7-sdk, java7-devel
instead of
jre, java, java-sdk, java-devel

Presumably, they did this to provide support for both being installed
at once, following RHEL's lead.
(FYI, this does not apply to Fedora, which does not mangle the virtual
packages, at least not in the the latest (F18). I haven't checked
other RPM-based systems).

Using "jre" as the virtual dependency, the RPM will accept either
OpenJDK (1.6 on RHEL/CentOS or 1.7 on Fedora) or Oracle's JVM, without
being explicitly tied to a version.

However, I wouldn't be too concerned about this. You can install both
on RHEL/CentOS systems easily. Accumulo will by default use whichever
$JAVA_HOME is resolved by `which java`, and you can manage that with
the alternatives system or by setting your path. The default with both
installed will be OpenJDK 1.7. Or, you can specify $JAVA_HOME
explicitly in your environment (or in conf/accumulo-env.sh), and that
will override Accumulo's trying to search for it.
--
Christopher L Tubbs II
http://gravatar.com/ctubbsii
On Tue, Jun 11, 2013 at 10:10 AM, Aaron <[EMAIL PROTECTED]> wrote:
> So, trying to use the RPMs to install Accumulo, ran into a issue, was
> curious if anyone had this same problem.
>
> Have Centos 6.4, OpenJDK 1.7, when we install accumulo via rpm, it looks
> like it wants to install Java1.6.
>
> Looking over the assemble.xml it there is the requirement to use "jre" and
> when you do use yum, it wants to install 1.6
>
> Anyone get around this, if we want to use 1.7 as our runtime?
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB