Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
MapReduce >> mail # user >> hadoop single user setup


+
Mapred Learn 2011-01-10, 22:35
Copy link to this message
-
Re: hadoop single user setup
When you run the Hadoop CLI command it spawns a java process which in turn
tries to connect to the namenode service. In this case, your client is
trying to reach the namenode at "localhost" on TCP port 9000.  That
connection is failing.  The likely reason is that your namenode service is
not running right now.  You can check this by doing a "netstat -an | grep
9000" to see if theres anything listening, which is unlikely.  If you don't
see any process bound to port 9000 then either start the namenode service,
or if you've already tried that, then check the namenode log to see why it
isn't running.  The location of the log files can vary but the file you'd be
interested in will have a name format like hadoop*namenode*.log

11/01/10 13:42:49 INFO ipc.Client: Retrying connect to server:
localhost/127.0.0
.1:9000. Already tried 0 time(s).

On Mon, Jan 10, 2011 at 2:35 PM, Mapred Learn <[EMAIL PROTECTED]>wrote:

> hi,
> I am a newbie and am  trying to setup hadoop in single user setup on my
> windows
> 7 machine.
> I followed steps at:
> http://hadoop.apache.org/common/docs/current/single_node_setup.html#L...<http://hadoop.apache.org/common/docs/current/single_node_setup.html#Local>
> but i keep on getting error:
> $ bin/hadoop fs -lsr
> 11/01/10 13:42:49 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
> .1:9000. Already tried 0 time(s).
> 11/01/10 13:42:51 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
> .1:9000. Already tried 1 time(s).
> on all hdfs commands.
>
> What is wrong here ?
>
> Thanks in advance
>
+
Mapred Learn 2011-01-10, 22:54