Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> Region in Transition


Copy link to this message
-
Re: Region in Transition
In the past when I have seen regions get locked in transition it is usually
a problem with the HMaster.  Seemingly a transition starts and succeeds
between region servers, but the HMaster may miss part of that communication
and think it is still in transition.  Then it keeps retrying but the node
is not where it expects anymore.  This doesn't affect normal operations,
except that the balancer cannot run while something is in transition.
 Restarting the HMaster always fixed this for me and had no adverse affects
that I could see.

On Mon, Oct 15, 2012 at 10:28 AM, Kevin O'dell <[EMAIL PROTECTED]>wrote:

> Lukas,
>
>   Sure, how long has it been since the restart?  You will need to give the
> regions time to transition and logs time to split.  Did the region
> in transition properly?  Can you please out a pastebin together of hbck
> -details full output so that I can take a look at it.  Once I have reviewed
> it, I should be able to provide you with a plan to out this back together.
>
> On Mon, Oct 15, 2012 at 10:24 AM, Lukáš Drbal <[EMAIL PROTECTED]>
> wrote:
>
> > Hello Kevin,
> >
> > thanks for response. I clear it now and start cluster, but now i have
> > many other's regions :(
> > Here is output from hbase hbck -fixmeta
> > http://pastebin.com/HqsPVLMi
> >
> > Any next hint?
> >
> > Thanks a lot
> >
> > 2012/10/15 Kevin O'dell <[EMAIL PROTECTED]>:
> > > Have you tried clearing out your Znode information?  Typically, when I
> > have
> > > encountered a RIT, we will bring down HBase and go to the ZKcli and
> clear
> > > out /hbase.  What do you see in the logs pertaining to the region?  If
> it
> > > is a region that has bad hfiles or something like that you will not be
> > able
> > > to easily get rid of it through clearing out the ZK.
> > >
> > > On Mon, Oct 15, 2012 at 8:59 AM, Lukáš Drbal <[EMAIL PROTECTED]>
> > wrote:
> > >
> > >> Oh sorry. My HBase version is 0.94.1 and hadoop 1.0.3
> > >>
> > >> I found this in master log http://pastebin.com/CYt5PZCL and this line
> > >> are repeated for all region servers.
> > >>
> > >> Can someone help me please?
> > >>
> > >
> > >
> > >
> > > --
> > > Kevin O'Dell
> > > Customer Operations Engineer, Cloudera
> >
> >
> >
> > --
> > Save The World - http://www.worldcommunitygrid.org/
> > http://www.worldcommunitygrid.org/stat/viewMemberInfo.do?userName=LesTR
> >
> > LesTR
> >
>
>
>
> --
> Kevin O'Dell
> Customer Operations Engineer, Cloudera
>