Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
MapReduce >> mail # user >> RE: Decomssion datanode - no response


+
Devaraj k 2013-07-05, 03:39
+
Azuryy Yu 2013-07-05, 03:45
+
Azuryy Yu 2013-07-05, 02:42
+
Devaraj k 2013-07-05, 03:14
Copy link to this message
-
Re: Decomssion datanode - no response
Try to give IPaddressofDatanode:50010
On Fri, Jul 5, 2013 at 12:25 PM, Azuryy Yu <[EMAIL PROTECTED]> wrote:

> I filed this issue at :
> https://issues.apache.org/jira/browse/HDFS-4959
>
>
> On Fri, Jul 5, 2013 at 1:06 PM, Azuryy Yu <[EMAIL PROTECTED]> wrote:
>
>> Client hasn't any connection problem.
>>
>>
>> On Fri, Jul 5, 2013 at 12:46 PM, Devaraj k <[EMAIL PROTECTED]> wrote:
>>
>>>  And also could you check whether the client is connecting to NameNode
>>> or any failure in connecting to the NN.****
>>>
>>> ** **
>>>
>>> Thanks****
>>>
>>> Devaraj k****
>>>
>>> ** **
>>>
>>> *From:* Azuryy Yu [mailto:[EMAIL PROTECTED]]
>>> *Sent:* 05 July 2013 09:15
>>>
>>> *To:* [EMAIL PROTECTED]
>>> *Subject:* Re: Decomssion datanode - no response****
>>>
>>>  ** **
>>>
>>> I added dfs.hosts.exclude before NN started.****
>>>
>>>  ****
>>>
>>> and I updated /usr/local/hadoop/conf/dfs_exclude whith new hosts, but It
>>> doesn't decomssion. ****
>>>
>>> ** **
>>>
>>> On Fri, Jul 5, 2013 at 11:39 AM, Devaraj k <[EMAIL PROTECTED]> wrote:
>>> ****
>>>
>>> When did you add this configuration in NN conf? ****
>>>
>>>   <property>
>>>     <name>dfs.hosts.exclude</name>
>>>     <value>/usr/local/hadoop/conf/dfs_exclude</value>
>>>   </property>****
>>>
>>>  ****
>>>
>>> If you have added this configuration after starting NN, it won’t take
>>> effect and need to restart NN.****
>>>
>>>  ****
>>>
>>> If you have added this config with the exclude file before NN start, you
>>> can update the file with new hosts and refreshNodes command can be issued,
>>> then newly updated the DN’s will be decommissioned.****
>>>
>>>  ****
>>>
>>> Thanks****
>>>
>>> Devaraj k****
>>>
>>>  ****
>>>
>>> *From:* Azuryy Yu [mailto:[EMAIL PROTECTED]]
>>> *Sent:* 05 July 2013 08:48
>>> *To:* [EMAIL PROTECTED]
>>> *Subject:* Re: Decomssion datanode - no response****
>>>
>>>  ****
>>>
>>> Thanks Devaraj,****
>>>
>>>  ****
>>>
>>> There are no any releated logs in the NN log and DN log.****
>>>
>>>  ****
>>>
>>> On Fri, Jul 5, 2013 at 11:14 AM, Devaraj k <[EMAIL PROTECTED]> wrote:
>>> ****
>>>
>>> Do you see any log related to this in Name Node logs when you issue
>>> refreshNodes dfsadmin command?****
>>>
>>>  ****
>>>
>>> Thanks****
>>>
>>> Devaraj k****
>>>
>>>  ****
>>>
>>> *From:* Azuryy Yu [mailto:[EMAIL PROTECTED]]
>>> *Sent:* 05 July 2013 08:12
>>> *To:* [EMAIL PROTECTED]
>>> *Subject:* Decomssion datanode - no response****
>>>
>>>  ****
>>>
>>> Hi,****
>>>
>>> I am using hadoop-2.0.5-alpha, and I added 5 datanodes into dfs_exclude,
>>> ****
>>>
>>>  ****
>>>
>>> hdfs-site.xml:****
>>>
>>>   <property>
>>>     <name>dfs.hosts.exclude</name>
>>>     <value>/usr/local/hadoop/conf/dfs_exclude</value>
>>>   </property>****
>>>
>>>  ****
>>>
>>> then:****
>>>
>>> hdfs dfsadmin -refreshNodes****
>>>
>>>  ****
>>>
>>> but there is no decomssion nodes showed on the webUI. and not any
>>> releated logs in the datanode log. what's wrong?****
>>>
>>>  ****
>>>
>>> ** **
>>>
>>
>>
>
--
Regards,
Varun Kumar.P
+
武泽胜 2013-07-08, 00:26
+
Azuryy Yu 2013-07-08, 03:34
+
武泽胜 2013-07-08, 04:29