Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Zookeeper >> mail # user >> Invalid config


Copy link to this message
-
Re: Invalid config
Did you put you zoo.cfg in the %ZOOKEEPER-HOME%/conf/ ? Or did you rename
you zoo-***.cfg to zoo.cfg?
2011/12/2 René Weinert <[EMAIL PROTECTED]>

> Hi!
>
> I tried to set up Zookeeper for the first time with the following request
> and error:
>
> ubuntu@ubuntu:~/zookeeper-3.3.3$ java -cp
> zookeeper-3.3.3.jar:lib/log4j-1.2.15.jar:conf
> org.apache.zookeeper.server.quorum.QuorumPeerMain zoo.cfg
> 2011-12-01 20:13:42,733 - INFO  [main:QuorumPeerConfig@90] - Reading
> configuration from: zoo.cfg
> 2011-12-01 20:13:42,736 - FATAL [main:QuorumPeerMain@83] - Invalid config,
> exiting abnormally
> org.apache.zookeeper.server.quorum.QuorumPeerConfig$ConfigException: Error
> processing zoo.cfg
>        at
>
> org.apache.zookeeper.server.quorum.QuorumPeerConfig.parse(QuorumPeerConfig.j
> ava:110)
>        at
>
> org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPee
> rMain.java:99)
>        at
>
> org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:7
> 6)
> Caused by: java.lang.IllegalArgumentException: zoo.cfg file is missing
>        at
>
> org.apache.zookeeper.server.quorum.QuorumPeerConfig.parse(QuorumPeerConfig.j
> ava:94)
>        ... 2 more
> Invalid config, exiting abnormally
>
>
> My config file (zookeeper/confi/zoo.cfg) is:
>
>
> # The number of milliseconds of each tick
> tickTime=2000
> # The number of ticks that the initial
> # synchronization phase can take
> initLimit=10
> # The number of ticks that can pass between
> # sending a request and getting an acknowledgement
> syncLimit=5
> # the directory where the snapshot is stored.
> dataDir=/data
> # the port at which the clients will connect
> clientPort=2181
>
> server.1=XXX.XXX.XXX.91:2888:3888
> server.2=XXX.XXX.XXX.92:2888:3888
> server.3=XXX.XXX.XXX.93:2888:3888
>
>
> and I have a file called "myid" (with the content "1") in the directory
> "zookeeper/data".
>
>
>
> Can you tell me what I have to change in order for it to work?
>
>
> Thanks!
> René
>
>