Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Kafka, mail # user - A consumer keeps stopping


+
Ke Ren 2012-08-25, 20:29
+
Patricio Echagüe 2012-08-25, 20:57
+
Guy Doulberg 2012-08-26, 05:54
+
Ke Ren 2012-08-26, 08:07
Copy link to this message
-
Re: A consumer keeps stopping
Guy Doulberg 2012-08-26, 09:02
We are using 0.7.1 and the zookeeper released with this version
and a name with alphanumberic characters...

In my case each time is was a different consumer stopping

Hope that helps

On 08/26/2012 11:07 AM, Ke Ren wrote:
> Hi Guy,
>
> which kafka and zookeeper version are you using? what does your group id
> look like? are you using number or string characters? We are using kafka
> 0.7.1 with the zookeeper in its package. I am going to try different group
> id. The strange thing is we are using group name like xxxservice and it's
> always the same consumer stopping. another consumer always works fine.
>
> Thanks,
>
> Ke
>
> On Sun, Aug 26, 2012 at 6:54 AM, Guy Doulberg <[EMAIL PROTECTED]>wrote:
>
>> Hi
>>
>> Since I am using a different consumer-group from the one that caused me
>> these problems, I haven't encountered these problems again.....
>>
>>
>>
>>
>> On 08/25/2012 11:57 PM, Patricio Echag�e wrote:
>>
>>> We have experienced the same issue and are still trying to figure out the
>>> cause.
>>> On Aug 25, 2012 1:29 PM, "Ke Ren" <[EMAIL PROTECTED]> wrote:
>>>
>>>   Hi guys,
>>>> I am running a kafka instance and a zookeeper instance on the same ec2
>>>> instance. I have 2 consumer groups on the same topic. They work fine for
>>>> few days but one of the consumers keeps stopping after few days. I can't
>>>> see any exception in my application logs or kafka log. The thread of the
>>>> stopping consumer is still running but consumer can't receive any
>>>> message.
>>>> Even I restart my application and it's still the same. I have to restart
>>>> zookeeper and kafka to make it back to normal.
>>>>
>>>> I used the following tool suggested by kafka docs and found owner is null
>>>> after consumer stops working. also its consumer offset won't change any
>>>> more.
>>>>
>>>> bin/kafka-run-class.sh kafka.tools.**ConsumerOffsetChecker --group
>>>> mygroup
>>>> --zkconnect 127.0.0.1:2181 --topic mytopic
>>>>
>>>> It's very similar with
>>>>
>>>> http://mail-archives.apache.**org/mod_mbox/incubator-kafka-**
>>>> users/201207.mbox/%3C4FF59B1A.**[EMAIL PROTECTED]%3E<http://mail-archives.apache.org/mod_mbox/incubator-kafka-users/201207.mbox/%[EMAIL PROTECTED]%3E>
>>>>
>>>> Any ideas about it?
>>>>
>>>> Thanks
>>>>
>>>> Ke
>>>>
>>>>
>>
+
Jun Rao 2012-08-26, 17:10
+
Ke Ren 2012-08-26, 17:27
+
Patricio Echagüe 2012-08-26, 18:08
+
Jun Rao 2012-08-26, 23:40
+
Ke Ren 2012-08-27, 10:31