With these settings, I think the plan is to get the patches in, mark them
experimental for some time, and once they are baked remove the experimental
label. Given that development model, it will be not intuitive to have
settings prefixed. If any user was using them in their POC, then they have
to be aware of that the setting changed once we declare that it is good to
Ideally, we should either (1) remove the feature from the code base because
it is not getting any attention, and nobody is using it (offheap cache I am
looking at you), or (2) fix them to make it more stable. Given that we are
not living in the ideal world, I would still suggest that on a
feature-by-feature basis, we should decide 1 or 2, and if there is some
interest in working on the patch, document that feature is experimental in
book + hbase-default.xml, code etc and keep the code. Otherwise nuke them.
Just my 2 cents.
On Mon, Jul 1, 2013 at 2:29 PM, Andrew Purtell <[EMAIL PROTECTED]> wrote:
> On Mon, Jul 1, 2013 at 2:18 PM, Jean-Daniel Cryans <[EMAIL PROTECTED]
> > Yeah, but there's a distinction between hbase.regionserver.maxlogs
> > which is only in the code and not experimental at all VS
> > hbase.offheapcache.percentage which enables something that we decided
> > was experimental.
> > My motivation for this discussion is about the latter
> Remove them from hbase-defaults?
> But either that or an 'experimental.' (or whatever) prefix is fine with me.
> Just seems like the latter is more hair to trim back later.
> Best regards,
> - Andy
> Problems worthy of attack prove their worth by hitting back. - Piet Hein
> (via Tom White)