Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo, mail # dev - Accumulo code style


+
Sean Busbey 2014-01-17, 04:44
+
John Vines 2014-01-17, 05:04
Copy link to this message
-
Re: Accumulo code style
Christopher 2014-01-21, 19:39
I'm not sure it really matters, except where things are in the public
API, but most people seem to be pretty consistent with mixedLowerCase
or, for constants, ALL_UPPER_CASE. I don't think anybody would care if
you changed non-public API stuff if you're already in that code to
meet those conventions. Personally, I don't find either to affect
readability much, but consistency is nice.

--
Christopher L Tubbs II
http://gravatar.com/ctubbsii
On Fri, Jan 17, 2014 at 12:04 AM, John Vines <[EMAIL PROTECTED]> wrote:
> mixedLowerCase has been the prevalent standard
>
>
> On Thu, Jan 16, 2014 at 11:44 PM, Sean Busbey <busbey+[EMAIL PROTECTED]>wrote:
>
>> Do we have an official set of coding conventions?
>>
>> There's a couple of things listed on the source guide page[1], and I know
>> we have the eclipse formatter[2].
>>
>> I was hoping for something more document oriented. Or a statement that we
>> use something like the sun standard[3] as a basis with the changes noted on
>> the source guide page.
>>
>> The proximal cause of this is that I noticed we have a mix of variables
>> named in mixedLowerCase and lower_separated_by_underscores.
>>
>> -Sean
>>
>> [1]: http://accumulo.apache.org/source.html#coding-practices
>> [2]: http://bit.ly/1abKQAl
>> [3]: http://www.oracle.com/technetwork/java/codeconv-138413.html
>>