Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Pig >> mail # dev >> Pig doesn't support Cassandra 2.x


Copy link to this message
-
Pig doesn't support Cassandra 2.x
When I try to use Pig (on any version) with latest version of Apache
Cassandra (2.0.0 or 2.0.1) I get this error:

ERROR 1070: Could not resolve CassandraStorage using imports:
[,org.apache.pig.builtin., org.apache.pig.impl.builtin.]

When I change from Cassandra 2.0.0 to Cassandra 1.2.8 pig works well.

---------
Additional info:
Pig versions: 0.12.1-SNAPSHOT, 0.12 and 0.11
Cassandra: 2.0.1, 2.0.0 and 1.2.8

Working setup: Cassandra 1.2.8 and Pig 0.12