Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> TestShell and shell issues.


Copy link to this message
-
Re: TestShell and shell issues.
Fixed.

Issue was not because of Ruby or anything like that.

Was simply because my tmp director was mounted with noexec (for security).

Mounting it with exec allows the tests to pass.

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Running org.apache.hadoop.hbase.client.TestShell
Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 92.454 sec

Results :

Tests run: 1, Failures: 0, Errors: 0, Skipped: 0

[INFO]
[INFO] --- maven-surefire-plugin:2.10:test (secondPartTestsExecution)
@ hbase ---
[INFO] Tests are skipped.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1:39.987s
[INFO] Finished at: Fri Mar 15 22:35:03 EDT 2013
[INFO] Final Memory: 25M/437M
[INFO] ------------------------------------------------------------------------

JM

2013/3/15 Jean-Marc Spaggiari <[EMAIL PROTECTED]>:
> I faced some issues today when running the TestShell.
>
> I tried the shell too and it's not working.
>
> Based on the logs, HBase seems to be working fine, but the shell is not
>
> jmspaggi@hbasetest:~/hbase/hbase-0.94.6$ bin/hbase shell
> java.lang.RuntimeException: java.lang.UnsatisfiedLinkError:
> /run/shm/tmp/jffi7682189782786951905.tmp:
> /run/shm/tmp/jffi7682189782786951905.tmp: failed to map segment from
> shared object: Operation not permitted
>         at com.kenai.jffi.Foreign$InValidInstanceHolder.getForeign(Foreign.java:90)
>         at com.kenai.jffi.Foreign.getInstance(Foreign.java:95)
>         at com.kenai.jffi.Library.openLibrary(Library.java:151)
> ...
>
> Which is strange since I'm able to access this file:
>
> jmspaggi@hbasetest:~/hbase/hbase-0.94.6$ touch
> /run/shm/tmp/jffi7682189782786951905.tmp
> jmspaggi@hbasetest:~/hbase/hbase-0.94.6$
>
>
> Regarding the rights on the directory:
> jmspaggi@hbasetest:~/hbase/hbase-0.94.6$ ll /run/shm/
> total 0
> drwxrwxrwx 20 root root 500 mar 15 21:57 tmp
>
> The shell entire strack trace is available there: http://pastebin.com/bW85UNKb
>
> My tmp folder is mapped to /run/shm to increase perfomances and there
> is 8GB available on this tmp drive. So it's not a disk space issue.
>
> If I remove the mapping to the memory drive and I use the hard drive
> for the tmp folder,
> -------------------------------------------------------
>  T E S T S
> -------------------------------------------------------
> Running org.apache.hadoop.hbase.client.TestShell
> Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 92.817 sec
>
> Results :
>
> Tests run: 1, Failures: 0, Errors: 0, Skipped: 0
>
> [INFO]
> [INFO] --- maven-surefire-plugin:2.10:test (secondPartTestsExecution)
> @ hbase ---
> [INFO] Tests are skipped.
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD SUCCESS
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 1:40.425s
> [INFO] Finished at: Fri Mar 15 22:04:36 EDT 2013
> [INFO] Final Memory: 26M/437M
> [INFO] ------------------------------------------------------------------------
>
> So something is not working on a memory drive, and I think it's more
> related to Ruby than HBase...
>
> JM