-Re: [jira] [Created] (HADOOP-9822) create constant maxCapacity in RetryCache rather than hard-coding 16 in RetryCache constructor
I do not think this is worth making a change. Even Java code has these kinds of instances. This is essentially private static used in one single class, only in the constructor. That said, if you still want to make this change, it is not maxCapacity. It is DEFAULT_INITIAL_CAPACITY.
On Aug 1, 2013, at 10:11 PM, "Tsuyoshi OZAWA (JIRA)" <[EMAIL PROTECTED]> wrote:
> Tsuyoshi OZAWA created HADOOP-9822:
> Summary: create constant maxCapacity in RetryCache rather than hard-coding 16 in RetryCache constructor
> Key: HADOOP-9822
> URL: https://issues.apache.org/jira/browse/HADOOP-9822
> Project: Hadoop Common
> Issue Type: Bug
> Reporter: Tsuyoshi OZAWA
> Assignee: Tsuyoshi OZAWA
> Priority: Minor
> The magic number "16" is also used in ClientId.BYTE_LENGTH, so hard-coding magic number "16" is a bit confusing.
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA administrators
> For more information on JIRA, see: http://www.atlassian.com/software/jira