Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Flume >> mail # dev >> Build failing due to incorrect hadoop-common jar version


Copy link to this message
-
Build failing due to incorrect hadoop-common jar version
Hello everyone,

Downloaded the code from flume git repo.

Trying to build it
mvn clean install -DskipTests

It gives me this error.

The project expects 1.0.1 version of jar which was never there at maven
central.

http://search.maven.org/#search|gav|1|g%3A%22org.apache.hadoop%22%20AND%20a%3A%22hadoop-common%22
[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-remote-resources-plugin:1.1:process
(default) on project flume-ng-morphline-solr-sink: Failed to resolve
dependencies for one or more projects in the reactor. Reason: Missing:
[ERROR] ----------
[ERROR] 1) org.apache.hadoop:hadoop-common:jar:1.0.1
[ERROR]
[ERROR] Try downloading the file manually from the project website.

[ERROR] Path to dependency:
[ERROR] 1)
org.apache.flume.flume-ng-sinks:flume-ng-morphline-solr-sink:jar:1.5.0-SNAPSHOT
[ERROR] 2) com.cloudera.cdk:cdk-morphlines-all:pom:0.6.0
[ERROR] 3) com.cloudera.cdk:cdk-morphlines-solr-core:jar:0.6.0
[ERROR] 4) org.apache.solr:solr-core:jar:4.4.0
[ERROR] 5) org.apache.hadoop:hadoop-common:jar:1.0.1

----------------
[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-remote-resources-plugin:1.1:process
(default) on project flume-ng-dist: Failed to resolve dependencies for one
or more projects in the reactor. Reason: Missing:
[ERROR] ----------
[ERROR] 1) org.apache.hadoop:hadoop-common:jar:1.0.1
[ERROR] Path to dependency:
[ERROR] 1) org.apache.flume:flume-ng-dist:pom:1.5.0-SNAPSHOT
[ERROR] 2)
org.apache.flume.flume-ng-sinks:flume-ng-morphline-solr-sink:jar:1.5.0-SNAPSHOT
[ERROR] 3) org.apache.hadoop:hadoop-common:jar:1.0.1

To fix the errors I added upfront dependency to latest hadoop common in

pom.xml for both these projects

  <dependency>
    <groupId>org.apache.hadoop</groupId>
    <artifactId>hadoop-common</artifactId>
    <version>2.1.0-beta</version>
</dependency>
And it builds successfully
I checked the build also , it failed

https://builds.apache.org/job/flume-trunk/492/

Seems its related to that

Should i open JIRA and submit patch for it ?

Thanks,

Jagat
+
Jagat Singh 2013-09-08, 04:14
+
Israel Ekpo 2013-09-08, 04:24
+
Jagat Singh 2013-09-08, 04:36
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB