Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo >> mail # dev >> Debugging MiniAccumuloTest


Copy link to this message
-
Debugging MiniAccumuloTest
I'm getting

java.lang.RuntimeException: Initialize process returned 255
    at
org.apache.accumulo.test.MiniAccumuloCluster.start(MiniAccumuloCluster.java:311)
    at
org.apache.accumulo.test.MiniAccumuloClusterTest.setupMiniCluster(MiniAccumuloClusterTest.java:65)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at
org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
    at
org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
    at
org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
    at
org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:24)
    at
org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
    at org.junit.runners.ParentRunner.run(ParentRunner.java:309)
    at
org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50)
    at
org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
    at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467)
    at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
    at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390)
    at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197)

and

java.io.IOException: Bad file descriptor
    at java.io.FileInputStream.readBytes(Native Method)
    at java.io.FileInputStream.read(FileInputStream.java:220)
    at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:264)
    at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:306)
    at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:158)
    at java.io.InputStreamReader.read(InputStreamReader.java:167)
    at java.io.BufferedReader.fill(BufferedReader.java:136)
    at java.io.BufferedReader.readLine(BufferedReader.java:299)
    at java.io.BufferedReader.readLine(BufferedReader.java:362)
    at
org.apache.accumulo.test.MiniAccumuloCluster$LogWriter.run(MiniAccumuloCluster.java:89)

from miniAccumuloTest in my working branch, which is breaking things.
Unfortunately, this is the only debug I seem to be getting and i cannot
figure out how to run the eclipse debugger to attach to the new Process. I
can do initialize with --instance-name and --password to set things outside
of it, so I'm really not sure why it's breaking here. Does anyone have any
tips on how to debug the MiniAccumulo cluster?
+
Keith Turner 2013-01-22, 20:23
+
John Vines 2013-01-22, 20:37
+
Christopher 2013-01-22, 20:46
+
John Vines 2013-01-22, 20:55
+
Keith Turner 2013-01-22, 21:08
+
Keith Turner 2013-01-22, 21:04