Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # dev >> hadoop 0.20.205.0 release candidate testing


Copy link to this message
-
Re: hadoop 0.20.205.0 release candidate testing
I applied the HBASE-4537 fix (just removed the imports) to 0.90, 0.92 and
trunk.

I also had problems with a missing commons-config jar initially, when I was
doing local Hadoop builds from the 205 branch.  But after doing a clean and
having the Hadoop build regenerate the hadoop-core POM with "ant
mvn-install", the HBase build then picked it up as a dependency.

If you run into other problems, please share!
On Tue, Oct 4, 2011 at 3:53 PM, Gary Helmling <[EMAIL PROTECTED]> wrote:

> HBASE-4515 mistakenly brought in the UnixUserGroupInformation reference as
> an import.  Created HBASE-4537 to clean it up.
>
>
>
> On Tue, Oct 4, 2011 at 3:09 PM, Stack <[EMAIL PROTECTED]> wrote:
>
>> I've been doing a bit of hadoop 0.20.205.0 release candidate testing
>> running tip of 0.90 branch on it.  I've run into a few issues so far.
>> Maybe folks here have some input.
>>
>> I get this if I try to have 0.90 build against it.  Indeed the class
>> is not present in 205.  Was wondering what I should use instead:
>>
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Compilation failure
>>
>> /home/stack/hbase-0.90.5-SNAPSHOT/src/test/java/org/apache/hadoop/hbase/security/TestUser.java:[28,33]
>> cannot find symbol
>> symbol  : class UnixUserGroupInformation
>> location: package org.apache.hadoop.security
>>
>> The last log when we split always has zero edits which seems off.
>>
>> To make it work you need to add commons-config to hbase lib dir and
>> set dfs.support.append=true in hbase-site.xml (maybe I need to set
>> that on the cluster too).
>>
>> The hbase web UI is missing its blue outline when running w/ tip of
>> 0.90.  Will look into that too.
>>
>> St.Ack
>>
>
>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB