Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> regions are not getting distributed


Copy link to this message
-
Re: regions are not getting distributed
I found the following from master log:

2013-08-23 19:23:12,791 INFO org.apache.hadoop.hbase.master.LoadBalancer:
Calculated a load balance in 24ms. Moving 2 regions off of 1 overloaded
servers onto 1 less loaded servers
2013-08-23 19:23:12,791 INFO org.apache.hadoop.hbase.master.HMaster:
balance hri=scores,,1377265725656.2dc3d895b55455dd06880fb0f15bb80d.,
src=vamshi,60020,1377265385768, dest=vamshi_RS,60020,1377265388499

Then:

2013-08-23 19:23:13,007 DEBUG
org.apache.hadoop.hbase.master.AssignmentManager: Handling
transition=RS_ZK_REGION_FAILED_OPEN, server=vamshi_RS,60020,1377265388499,
region=2dc3d895b55455dd06880fb0f15bb80d
2013-08-23 19:23:13,007 DEBUG
org.apache.hadoop.hbase.master.AssignmentManager: Found an existing plan
for scores,,1377265725656.2dc3d895b55455dd06880fb0f15bb80d. destination
server is vamshi_RS,60020,1377265388499
2013-08-23 19:23:13,007 DEBUG
org.apache.hadoop.hbase.master.AssignmentManager: No previous transition
plan was found (or we are ignoring an existing plan) for
scores,,1377265725656.2dc3d895b55455dd06880fb0f15bb80d. so generated a
random one; hri=scores,,1377265725656.2dc3d895b55455dd06880fb0f15bb80d.,
src=, dest=vamshi,60020,1377265385768; 2 (online=2, available=1) available
servers

Can you check region server log for vamshi_RS to see why the region failed
to open ?
On Fri, Aug 23, 2013 at 7:18 AM, Vamshi Krishna <[EMAIL PROTECTED]>wrote:

> I am using hbase-0.90.4  and zookeeper-3.4.5
> Please find the pastebin link here. I copied my master log there.
> http://pastebin.com/jpuZqHnT
>
> I could find few balancer related lines but, the appropriate action (i.e
> moving appropriate number of regions to other server ) is not reflected in
> the web UI http://<hostname>:60010.
> All the tables that i created are residing on the same machine-1.
>
>
> On Fri, Aug 23, 2013 at 7:36 PM, Ted Yu <[EMAIL PROTECTED]> wrote:
>
> > What version of HBase are you using ?
> >
> > Can you search in master log for balancer related lines ?
> >
> > Thanks
> >
> >
> > On Fri, Aug 23, 2013 at 7:00 AM, Vamshi Krishna <[EMAIL PROTECTED]
> > >wrote:
> >
> > > Hello all,
> > >             I set up a 2 node hbase cluster. I inserted million rows in
> > to
> > > hbase table. Machine1-master and region server
> > > machine-2-only region server.
> > > After the insertion completed, Still i see the 4 regions formed for the
> > > inserted table are residing on the machine -1 only. I waited more than
> 5
> > > minutes, as the default balancer period is 5min from hbase apache
> > > documentation. But, still i notice all the 4 regions of the table are
> on
> > > machine-1 only. not distributed automatically.
> > > I even enabled the balancer from shell using     "balance_switch true"
> > but
> > > no result even after 5 min.
> > >
> > > Could any one tell me why is it happening so.?
> > >
> > >
> > > --
> > > *Regards*
> > > *
> > > Vamshi Krishna
> > > *
> > >
> >
>
>
>
> --
> *Regards*
> *
> Vamshi Krishna
> *
>