Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Sqoop >> mail # dev >> Sqoop2 server not staring when Oozie server started


Copy link to this message
-
Re: Sqoop2 server not staring when Oozie server started
Hi Jarek,

Below given Catalina logs
I'm using Oozie version : 3.0.2 which is old version which is using tomcat
admin port default value.

Recent Oozie(3.3.2) version has changed admin port to 11001.
<Server port="${oozie.admin.port}" shutdown="SHUTDOWN">

But Sqoop2 uses tomcat default value.
<Server port="8005" shutdown="SHUTDOWN">

We can introduce the new sqoop webserver admin port value. This will solves
the problem. So users can use oozie-3.0.2 version as well in same machine.
I tried modifying the admin port 8005 to 12001 and both working fine.
Below sqoop2 and oozie 3.0.2 version using 8005.
Sqoop2: server/logs/catalina.out. Starting at 12000

31 Mar, 2013 10:14:30 AM org.apache.catalina.startup.HostConfig
deployDirectory
INFO: Deploying web application directory ROOT
31 Mar, 2013 10:14:30 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-*12000*
31 Mar, 2013 10:14:30 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
31 Mar, 2013 10:14:30 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/18  config=null
31 Mar, 2013 10:14:30 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 2644 ms
31 Mar, 2013 10:14:30 AM org.apache.catalina.core.StandardServer await
SEVERE: StandardServer.await: create[8005]:
java.net.BindException: Address already in use
    at java.net.PlainSocketImpl.socketBind(Native Method)
    at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:383)
    at java.net.ServerSocket.bind(ServerSocket.java:328)
    at java.net.ServerSocket.<init>(ServerSocket.java:194)
    at
org.apache.catalina.core.StandardServer.await(StandardServer.java:406)
    at org.apache.catalina.startup.Catalina.await(Catalina.java:676)
    at org.apache.catalina.startup.Catalina.start(Catalina.java:628)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
31 Mar, 2013 10:14:30 AM org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-*12000*
31 Mar, 2013 10:14:31 AM org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina

Oozie log:

31 Mar, 2013 10:14:02 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-*11000*
31 Mar, 2013 10:14:02 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 625 ms
31 Mar, 2013 10:14:02 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
31 Mar, 2013 10:14:02 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.32
31 Mar, 2013 10:14:02 AM org.apache.catalina.startup.HostConfig
deployDescriptor
INFO: Deploying configuration descriptor oozie.xml
31 Mar, 2013 10:14:06 AM org.apache.catalina.startup.HostConfig
deployDirectory
INFO: Deploying web application directory ROOT
31 Mar, 2013 10:14:06 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-*11000*
31 Mar, 2013 10:14:06 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 4405 ms

On Sun, Mar 31, 2013 at 6:20 AM, Jarek Jarcec Cecho <[EMAIL PROTECTED]>wrote:

> Hi Vasanth,
> thank you very much for finding this one. I think that both Sqoop and
> Oozie should be able to run side by side on one single machine. Would you
> mind sharing logs with the errors you're seeing? I think that each server
> is starting with different port (Sqoop 12000, Oozie 11000), so I do not
> immediately see where they would block each other.
>
> Jarcec
>
> On Sun, Mar 31, 2013 at 03:05:15AM +0530, vasanth kumar wrote:
> > Hi,
> >
> > Sqoop2 server is not starting if Oozie is started and vice-versa because

Regards
Vasanth kumar RJ