Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Chukwa, mail # user - problem with hadoop version2 ( IPC version 7 ) and chukwa 0.5


Copy link to this message
-
Re: problem with hadoop version2 ( IPC version 7 ) and chukwa 0.5
Eric Yang 2013-02-02, 18:59
Yes, if the hadoop/hbase/zookeeper jar files are packaged in hicc.war, then
you should replace those too.  But I am not sure if that was the source of
the problem.  Can you show more of the stack trace to determine the
problem.  This looks like a configuration property is missing.  I am not
sure if it is hdfs, hbase, or zookeeper related.

regards,
Eric

On Sat, Feb 2, 2013 at 10:50 AM, Farrokh Shahriari <
[EMAIL PROTECTED]> wrote:

> Yeah,you were right,I should've update zookeeper.jar.
> Now there is another probelm,when I've run chukwa hicc,I've got this error
> :
>
> java.lang.IllegalArgumentException: Not a host: port pair:
>
> I read in a place that the hbase jar files should be updated ( I copied my
> hbase jar files to share/chukwa/lib/ ),but still have problem, should I
> change the inside of hicc.war too ?
>
> Tnx
>
>
> On Sat, Feb 2, 2013 at 9:13 PM, Eric Yang <[EMAIL PROTECTED]> wrote:
>
>> Make sure you also update HBase jar file and ZooKeeper jar files to your
>> versions.
>>
>> regards,
>> Eric
>>
>>
>> On Fri, Feb 1, 2013 at 9:08 PM, Farrokh Shahriari <
>> [EMAIL PROTECTED]> wrote:
>>
>>> Tnx Eric,
>>> but my chukwa classpath is this :
>>>
>>> export CLASSPATH=${CLASSPATH}:${HBASE_CONF_DIR}:${HADOOP_CONF_DIR}
>>> export HBASE_CONF_DIR="${HBASE_CONF_DIR}"
>>> export HADOOP_CONF_DIR="/etc/hadoop/conf/"
>>>
>>> And I've deleted the hadoop-core-1.0.0.jar,hadoop-test-1.0.0.jar from
>>> "chukwa-0.5.0/share/chukwa/lib/" as the manual said, but still I've got
>>> errors.
>>>
>>>
>>> On Fri, Feb 1, 2013 at 9:07 AM, Eric Yang <[EMAIL PROTECTED]> wrote:
>>>
>>>> Is there multiple version of hadoop jar files in the class path?  This
>>>> error looks like hdfs client is from Hadoop 1.x.  If there is older version
>>>> of hadoop-core*.jar file, it can generate this error.
>>>>
>>>> regards,
>>>> Eric
>>>>
>>>>
>>>> On Tue, Jan 29, 2013 at 11:24 PM, Farrokh Shahriari <
>>>> [EMAIL PROTECTED]> wrote:
>>>>
>>>>> Hi there,
>>>>> I downloaded & installed chuckwa 0.5 on hadoop version 2 (cdh
>>>>> 4.0.0).But when collector runs,it has showed this error :
>>>>> Server IPC version 7 cannot communicate with client version 4
>>>>>
>>>>> I copied lib from /user/lib/hadoop/*.jar &
>>>>> /user/lib/hadoop-hdfs/*.jar, but couldn't get result.
>>>>>
>>>>> I'd be glad if someone can help me.
>>>>> Tnx
>>>>>
>>>>
>>>>
>>>
>>
>