Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # dev >> Compile does not work against Hadoop-1.0.0 - 1.0.2


Copy link to this message
-
Re: Compile does not work against Hadoop-1.0.0 - 1.0.2
Is there a valid reason for using a Hadoop version older than 1.0.3 if
compiling up your own deploy?
On Wed, Apr 24, 2013 at 6:29 PM, Enis Söztutar <[EMAIL PROTECTED]> wrote:

> While trying with older Hadoop versions, I noticed that we do not compile
> against hadoop versions older than 1.0.3.
>
> I think the programmatic kerberos jaas configuration broke the compat:
> The error is:
>
> [ERROR]
>
> /Users/enis/projects/hbase/hbase-client/src/main/java/org/apache/hadoop/hbase/zookeeper/ZKUtil.java:[36,53]
> cannot find symbol
> symbol  : class KerberosUtil
> location: package org.apache.hadoop.security.authentication.util
> [ERROR]
>
> /Users/enis/projects/hbase/hbase-client/src/main/java/org/apache/hadoop/hbase/zookeeper/ZKUtil.java:[247,32]
> cannot find symbol
> symbol  : variable KerberosUtil
> location: class org.apache.hadoop.hbase.zookeeper.ZKUtil.JaasConfiguration
>
>
> Should we fix this, or just document the case, and not work with older
> hadoop versions than 1.0.3
>
> Enis
>

--
Best regards,

   - Andy

Problems worthy of attack prove their worth by hitting back. - Piet Hein
(via Tom White)