Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # user >> hbase error


+
wanli gao 2012-11-21, 15:44
+
Stack 2012-11-21, 17:32
+
wanli gao 2012-11-21, 17:42
+
Jean-Marc Spaggiari 2012-11-21, 17:46
+
Mohammad Tariq 2012-11-21, 17:51
+
wanli gao 2012-11-21, 18:00
+
Mohammad Tariq 2012-11-21, 18:05
+
wanli gao 2012-11-22, 01:45
Hello Wanli,

Try checking /etc/hosts . Make sure that both localhost and <your machine
name> are set to 127.0.0.1, and not 127.0.1.1 . Some distributions do that
and it will sometimes give strange errors.

Mohamed Ibrahim
On Wed, Nov 21, 2012 at 8:45 PM, wanli gao <[EMAIL PROTECTED]> wrote:

> hi, Mohammad
> i configure hbase according to your wrote, but it give the same error.
> Trying to contact region server null for region , row '', but failed
> after 3 attempts.
> i open RegionServer`s webui,and it `s just one server was running :named
> -ROOT-,,0
> is it correct that just one server running.is here should run a meta
> region server?
> 于 2012年11月22日 02:05, Mohammad Tariq 写道:
> > I have outlined the process here :
> >
> http://cloudfront.blogspot.in/2012/06/how-to-configure-habse-in-pseudo.html
> > See if it is of any help to you.
> >
> > Regards,
> >     Mohammad Tariq
> >
> >
> >
> > On Wed, Nov 21, 2012 at 11:30 PM, wanli gao <[EMAIL PROTECTED]> wrote:
> >
> >> i don`t change HBASE_MANAGES_ZK, it`s default
> >> and i try latest version,but it can`t connect to hdfs
> >> 于 2012年11月22日 01:51, Mohammad Tariq 写道:
> >>> Hello Wanli,
> >>>
> >>>     Have you set the  HBASE_MANAGES_ZK property in your hbase-env.sh
> file
> >>> to 'true'? Aslo, I would suggest you to use the latest stable release.
> >>>
> >>> Regards,
> >>>     Mohammad Tariq
> >>>
> >>>
> >>>
> >>> On Wed, Nov 21, 2012 at 11:16 PM, Jean-Marc Spaggiari <
> >>> [EMAIL PROTECTED]> wrote:
> >>>
> >>>> Hi Wanli,
> >>>>
> >>>> I can see that on your logs:
> >>>>
> >>>> Failed to read: org.apache.zookeeper.KeeperException$NoNodeException:
> >>>> KeeperErrorCode = NoNode for /hbase/root-region-server
> >>>>
> >>>> and Read ZNode /hbase/root-region-server got 127.0.0.1:60020
> >>>>
> >>>> It's connecting locally, no? Do you have your Quorum configured on
> >>>> your hbase-site.xml
> >>>>
> >>>> On your master, what is "bin/hbase zkcli" giving?
> >>>>
> >>>> JM
> >>>>
> >>>> 2012/11/21, wanli gao <[EMAIL PROTECTED]>:
> >>>>> zookeeper is running well,
> >>>>> regionserver log:
> >>>>> 2012-11-22 00:54:53,773 INFO
> >>>>> org.apache.hadoop.hbase.regionserver.HRegionServer: HRegionServer
> >>>>> started at: 127.0.0.1:60020
> >>>>> 2012-11-22 00:54:53,774 INFO org.apache.hadoop.ipc.HBaseServer: IPC
> >>>>> Server handler 24 on 60020: starting
> >>>>> 2012-11-22 00:54:53,774 DEBUG
> >>>>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper: Failed to read:
> >>>>> org.apache.zookeeper.KeeperException$NoNodeException:
> KeeperErrorCode > >>>>> NoNode for /hbase/root-region-server
> >>>>> 2012-11-22 00:54:53,791 INFO
> >>>>> org.apache.hadoop.hbase.regionserver.StoreFile: Allocating
> >> LruBlockCache
> >>>>> with maximum size 197.4m
> >>>>> 2012-11-22 00:54:53,812 INFO
> >>>>> org.apache.hadoop.hbase.regionserver.HRegionServer: MSG_REGION_OPEN:
> >>>>> -ROOT-,,0
> >>>>> 2012-11-22 00:54:53,815 INFO
> >>>>> org.apache.hadoop.hbase.regionserver.HRegionServer: Worker:
> >>>>> MSG_REGION_OPEN: -ROOT-,,0
> >>>>> 2012-11-22 00:54:53,841 DEBUG
> >>>>> org.apache.hadoop.hbase.regionserver.HRegion: Creating region
> >> -ROOT-,,0,
> >>>>> encoded=70236052
> >>>>> 2012-11-22 00:54:53,871 INFO
> >>>>> org.apache.hadoop.hbase.regionserver.HRegion: region
> -ROOT-,,0/70236052
> >>>>> available; sequence id is 0
> >>>>> 2012-11-22 00:54:53,897 DEBUG
> >>>>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper: Failed to read:
> >>>>> org.apache.zookeeper.KeeperException$NoNodeException:
> KeeperErrorCode > >>>>> NoNode for /hbase/root-region-server
> >>>>> 2012-11-22 00:54:54,938 DEBUG
> >>>>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper: Read ZNode
> >>>>> /hbase/root-region-server got 127.0.0.1:60020
> >>>>> 2012-11-22 00:55:53,808 DEBUG
> >>>>> org.apache.hadoop.hbase.io.hfile.LruBlockCache: Cache Stats: Sizes:
> >>>>> Total=0.9263153MB (971312), Free=196.52368MB (206070016),
> Max=197.45MB
> >>>>> (207041328), Counts: Blocks=0, Access=0, Hit=0, Miss=0, Evictions=0,
> >>>>> Evicted=0, Ratios: Hit Ratio=NaN%, Miss Ratio=NaN%, Evicted/Run=NaN
+
wanli gao 2012-11-22, 02:37
+
wanli gao 2012-11-21, 17:54
+
wanli gao 2012-11-21, 16:32
+
anil gupta 2012-11-21, 17:06
+
Jean-Marc Spaggiari 2012-11-21, 17:25
+
wanli gao 2012-11-21, 17:35