Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # dev >> remove wikisearch from 1.4.x development?


Copy link to this message
-
Re: remove wikisearch from 1.4.x development?
On Mon, Oct 21, 2013 at 8:40 PM, Josh Elser <[EMAIL PROTECTED]> wrote:

> On 10/21/13 5:27 PM, Sean Busbey wrote:
>
>> On Oct 21, 2013 6:36 PM, "Josh Elser" <[EMAIL PROTECTED]> wrote:
>>
>>>
>>> On 10/21/13 3:46 PM, Keith Turner wrote:
>>>
>>>>
>>>> On Mon, Oct 21, 2013 at 6:11 PM, Sean Busbey <[EMAIL PROTECTED]>
>>>> wrote:
>>>>
>>>>  Heya,
>>>>>
>>>>> Back in the early days of 1.5 work, there was a Jira the move
>>>>> Wikisearch
>>>>> out into its contrib repo[1].
>>>>>
>>>>> For whatever reason, removing it didn't include the 1.4.x branch.
>>>>>
>>>> Before I
>>
>>> file a jira to remove it, was there any particular reason for keeping
>>>>> another code base in the 1.4 branch?
>>>>>
>>>>>
>>>>
>>>> I think the reasoning at the time was that it was in 1.4.0 and removing
>>>>
>>> it
>>
>>> would not be a bug fix.
>>>>
>>>
>>>
>>> Yeah, this. It's not hurting anything by being there -- it was just
>>>
>> decided to be lifted out in later versions
>>
>
> Another reason as to why I'm not really for backporting the hadoop-2
> support to 1.4 ;)
>
>
>
>> it does increase the maintenance costs for 1.4. For example, it contains
>> some parts that will require Hadoop version specific updates for
>> ACCUMULO-1792.
>>
>> Since Wikisearch isn't needed to run Accumulo and isn't in the defined
>> client API, why are changes to it considered breaking?
>>
>
> I wouldn't really have a problem removing wikisearch for a 1.4.5. I would
> just want to see something in the release notes pointing users to the git
> repo. IMO, there's absolutely no reason to fix up that code to make it work
> with hadoop-1 and hadoop-2.
I also would not oppose removing it.   At the time the decision was made,
there was no cost to leaving it in 1.4.  If it is removed, will whats
currently in contrib work against 1.4+Hadoop 1.0?
>
>
>  Someone have a subject line to help me search the archives for the
>> previous
>> discussion?
>>
>>