Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka >> mail # dev >> [jira] [Commented] (KAFKA-717) scala 2.10 build support


Copy link to this message
-
[jira] [Commented] (KAFKA-717) scala 2.10 build support

    [ https://issues.apache.org/jira/browse/KAFKA-717?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13697490#comment-13697490 ]

Sriram Subramanian commented on KAFKA-717:
------------------------------------------

I get the following errors when I try to apply the patches to 0.8 in the order that were added on 14th Jun -

1. patch 1 failed

../Downloads/0001-common-changes-for-2.10.patch:34: trailing whitespace.
unmanagedSourceDirectories in Compile <+= (sourceDirectory in Compile, scalaVersion){ (s,v) =>
../Downloads/0001-common-changes-for-2.10.patch:36: trailing whitespace.
    case v if v.startsWith("2.8.") => "2.8.x"
../Downloads/0001-common-changes-for-2.10.patch:38: trailing whitespace.
  }))
../Downloads/0001-common-changes-for-2.10.patch:54: trailing whitespace.
 *
../Downloads/0001-common-changes-for-2.10.patch:69: trailing whitespace.
 * Indicates that the annotated class is meant to be threadsafe. For an abstract class it is an part of the interface that an implementation
error: patch failed: project/Build.scala:28
error: project/Build.scala: patch does not apply

2. patch 3 failed

error: patch failed: project/Build.scala:28
error: project/Build.scala: patch does not apply

3. patch 4 failed

error: patch failed: core/build.sbt:22
error: core/build.sbt: patch does not apply
error: patch failed: core/src/test/scala/unit/kafka/metrics/KafkaTimerTest.scala:36
error: core/src/test/scala/unit/kafka/metrics/KafkaTimerTest.scala: patch does not apply
error: patch failed: project/Build.scala:28
error: project/Build.scala: patch does not apply
I used git apply
                
> scala 2.10 build support
> ------------------------
>
>                 Key: KAFKA-717
>                 URL: https://issues.apache.org/jira/browse/KAFKA-717
>             Project: Kafka
>          Issue Type: Improvement
>          Components: packaging
>    Affects Versions: 0.8
>            Reporter: Viktor Taranenko
>              Labels: build
>         Attachments: 0001-common-changes-for-2.10.patch, 0001-common-changes-for-2.10.patch, 0001-KAFKA-717-Convert-to-scala-2.10.patch, 0002-java-conversions-changes.patch, 0002-java-conversions-changes.patch, 0003-add-2.9.3.patch, 0003-add-2.9.3.patch, 0004-Fix-cross-compile-of-tests-update-to-2.10.2-and-set-.patch, KAFKA-717-complex.patch, KAFKA-717-simple.patch, kafka_scala_2.10.tar.gz
>
>
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

 
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB