Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka >> mail # dev >> Review Request 23516: Patch for KAFKA-1462


Copy link to this message
-
Re: Review Request 23516: Patch for KAFKA-1462

This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23516/#review47954

clients/src/main/java/org/apache/kafka/common/Cluster.java
<https://reviews.apache.org/r/23516/#comment84197>

    This should ideally be
      List<PartitionInfo> partitionsForTopic(String topic)

clients/src/main/java/org/apache/kafka/common/protocol/types/Struct.java
<https://reviews.apache.org/r/23516/#comment84198>

    If we override equals we need to also override hashCode. Also think if we need to add a test to ProtocolSerializationTest

clients/src/main/java/org/apache/kafka/common/requests/GenericStruct.java
<https://reviews.apache.org/r/23516/#comment84199>

    Can we come up with a better name? Structs are already generic. I think this is something like AbstractRequestResponse?

clients/src/main/java/org/apache/kafka/common/requests/GenericStruct.java
<https://reviews.apache.org/r/23516/#comment84201>

    These group by methods don't belong in a generic base class.

clients/src/main/java/org/apache/kafka/common/requests/GenericStruct.java
<https://reviews.apache.org/r/23516/#comment84200>

    hashCode
- Jay Kreps
On July 15, 2014, 6:36 p.m., Jun Rao wrote: