Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka >> mail # dev >> urgent request for kafka 0.8


Copy link to this message
-
urgent request for kafka 0.8
I just updated my kafka 0.8 this morning.

After that I am not able to run kafka any more.

The error msg I got is for producer:

13/01/28 11:23:57 ERROR async.DefaultEventHandler: Failed to send messages
java.lang.NoClassDefFoundError: org/xerial/snappy/SnappyOutputStream
at
kafka.message.ByteBufferMessageSet$.kafka$message$ByteBufferMessageSet$$create(ByteBufferMessageSet.scala:41)
at kafka.message.ByteBufferMessageSet.<init>(ByteBufferMessageSet.scala:98)
at
kafka.producer.async.DefaultEventHandler$$anonfun$4.apply(DefaultEventHandler.scala:291)
at
kafka.producer.async.DefaultEventHandler$$anonfun$4.apply(DefaultEventHandler.scala:279)
at
scala.collection.TraversableLike$$anonfun$map$1.apply(TraversableLike.scala:233)
at
scala.collection.TraversableLike$$anonfun$map$1.apply(TraversableLike.scala:233)
at
scala.collection.mutable.HashMap$$anonfun$foreach$1.apply(HashMap.scala:95)

I noticed the latest version of 0.8 has some changes and the snappy related
.jars are removed. As a result,
I do not have a jar file to fix this issue.  Can you fix it a.s.a.p? We are
blocked. Or, provide a snappy jar
with the right version?

Highly highly appreciated!

Jane