Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka >> mail # user >> Upgrade to Zookeeper 3.4.5 stable ?


Copy link to this message
-
Re: Upgrade to Zookeeper 3.4.5 stable ?
We've upgraded our ZK installation to 3.4.5 (by using the apt package from
CDH) about a month ago and have been running it since without much issue.

In our case, the only problem is that our previous installation of ZK had
unlimited client connections (maxClientCnxns=0) and the vanilla CDH
installation defaulted this setting to 50, so we hit connection limits in
our particular environment. We raised that config value higher and have
been running smoothly since.

As for the snapshot retention, we chose not to use ZK 3.4.x's built-in
clean up capabilities because the cron job we already had was more flexible
(with different retention times for snapshots and transaction logs).

Cheers :) !

--
Felix
On Thu, Jun 20, 2013 at 9:37 PM, Matt Christiansen <[EMAIL PROTECTED]> wrote:

> I have been using ZK 3.4.5 in production for about 6 months now with out
> any issues, Kafka, HBase, HDFS HA, our own apps all seem to work fine with
> it. It also has some nice operational upgrades including auto expiring of
> the log and snapshots.
>
>
> On Tue, Jun 18, 2013 at 8:56 AM, Jun Rao <[EMAIL PROTECTED]> wrote:
>
> > We do plan to look into upgrading to ZK 3.4.5 at some point, especially
> for
> > picking up the multi() feature. ZK 3.4.5 should be backward compatible.
> Do
> > you know how stable it is?
> >
> > Thanks,
> >
> > Jun
> >
> >
> > On Mon, Jun 17, 2013 at 9:36 PM, Ran RanUser <[EMAIL PROTECTED]>
> wrote:
> >
> > > I'm running Zookeeper 3.4.5 server and using 3.4.5 clients in other
> code.
> > >
> > > Will Kafka switch to Zookeeper 3.4.5 soon?
> > >
> > > Should I expect any potential issues if Kafka's Zookeeper client is
> 3.3.4
> > > while our server is 3.4.5?
> > >
> > > Thanks!
> > >
> >
>