Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka >> mail # dev >> Review Request 23339: Patch for KAFKA-1507


Copy link to this message
-
Re: Review Request 23339: Patch for KAFKA-1507

Thanks for the review. I've noticed NetworkClient.java always uses the latestVersion of an api. There doesn't look like the way I can send specific version of a request since the nextRequestHeader doesn't accept a version. Even if I am creating a version 0 of a request the requestheader will go with latest version of that particular request. Is there any reason to keep version as part of request header rather than inside of a request structure and we expect NetworkClient to use the latest version?.
- Sriharsha
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23339/#review48397
On July 24, 2014, 12:07 a.m., Sriharsha Chintalapani wrote: