Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka >> mail # user >> There is insufficient memory for the Java Runtime Environment to continue.


Copy link to this message
-
Re: There is insufficient memory for the Java Runtime Environment to continue.
Do you have anything like Graphite or Ganglia monitoring the box to see
exactly what's going on?
On Fri, Jan 31, 2014 at 1:45 PM, David Montgomery <[EMAIL PROTECTED]
> wrote:

> Welll...I did get kafka to run on a digiocean box with 4 gigs or ram.  All
> great but now i am paying 40 USD a month for dev servers when I was paying
> 5.  I have 5 dev servers around the worlds.  Would be great to get back ot
> 5 USD for boxes that just need to start up rather just doing anything
> substantial.
>
> Going back to the original issue.  Is this the only lever I have to get
> kafka to work on a 512megs ram box?  KAFKA_HEAP_OPTS="-Xmx256M -Xms128M?
> Any other trick?
>
> Thanks
>
>
>
> On Sat, Feb 1, 2014 at 5:21 AM, Benjamin Black <[EMAIL PROTECTED]> wrote:
>
> > Sorry, was looking at pre-release 0.8 code. No idea now why they are not
> > being set as expected.
> >
> >
> > On Fri, Jan 31, 2014 at 1:20 PM, Benjamin Black <[EMAIL PROTECTED]> wrote:
> >
> > > kafka-run-class.sh in 0.8 does not define KAFKA_HEAP_OPTS. i think you
> > > want KAFKA_OPTS.
> > >
> > >
> > > On Fri, Jan 31, 2014 at 1:14 PM, David Montgomery <
> > > [EMAIL PROTECTED]> wrote:
> > >
> > >> What d you mean?
> > >>
> > >> This is appended to kafka-run-class.sh
> > >>
> > >> KAFKA_JMX_OPTS="-Dcom.sun.management.jmxremote=true
> > >> -Dcom.sun.management.jmxremote.authenticate=false
> > >> -Dcom.sun.management.jmxremote.ssl=false"
> > >>
> > >> prior to running the below in the shel I run =>  export
> > >> KAFKA_HEAP_OPTS="-Xmx1G -Xms1G"
> > >>
> > >> I start kafka like this:
> > >> /var/lib/kafka-0.8.0-src/bin/kafka-server-start.sh
> > >> /var/lib/kafka-0.8.0-src/config/server.properties
> > >>
> > >> What else is there do?  I did not have an issue with kafka 7.  Only 8.
> > >>
> > >> Thanks
> > >>
> > >>
> > >>
> > >>
> > >>
> > >>
> > >>
> > >>
> > >> On Fri, Jan 31, 2014 at 4:47 AM, Benjamin Black <[EMAIL PROTECTED]> wrote:
> > >>
> > >> > are you sure the java opts are being set as you expect?
> > >> > On Jan 30, 2014 12:41 PM, "David Montgomery" <
> > [EMAIL PROTECTED]
> > >> >
> > >> > wrote:
> > >> >
> > >> > > Hi,
> > >> > >
> > >> > > This is a dedicated machine on DO.    But i can say I did not
> have a
> > >> > > problem with kafka 7.
> > >> > > I just upgraded the macine to 1gig on digi ocean.  Same error.
> > >> > >
> > >> > > export KAFKA_HEAP_OPTS="-Xmx1G -Xms1G"
> > >> > > root@do-kafka-sf-development-20140130195343
> :/etc/supervisor/conf.d#
> > >> > > /var/lib/kafka-0.8.0-src/bin/kafka-server-start.sh
> > >> > > /var/lib/kafka-0.8.0-src/config/server.properties
> > >> > > OpenJDK 64-Bit Server VM warning: INFO:
> > >> > > os::commit_memory(0x00000000bad30000, 986513408, 0) failed;
> > >> error='Cannot
> > >> > > allocate memory' (errno=12)
> > >> > > #
> > >> > > # There is insufficient memory for the Java Runtime Environment to
> > >> > > continue.
> > >> > > # Native memory allocation (malloc) failed to allocate 986513408
> > bytes
> > >> > for
> > >> > > committing reserved memory.
> > >> > > # An error report file with more information is saved as:
> > >> > > # /etc/supervisor/conf.d/hs_err_pid11635.log
> > >> > >
> > >> > >
> > >> > >
> > >> > > Below is how I install via chef
> > >> > >
> > >> > >     version = '0.8.0'
> > >> > >     tar -xzf kafka-#{version}-src.tgz
> > >> > >     cd kafka-#{version}-src
> > >> > >     ./sbt update
> > >> > >     ./sbt package
> > >> > >     ./sbt assembly-package-dependency
> > >> > >     echo 'KAFKA_JMX_OPTS="-Dcom.sun.management.jmxremote=true
> > >> > > -Dcom.sun.management.jmxremote.authenticate=false
> > >> > > -Dcom.sun.management.jmxremote.ssl=false"' | tee -a
> > >> > > /var/lib/kafka-#{version}-src/bin/kafka-run-class.sh
> > >> > >     echo 'export JMX_PORT=${JMX_PORT:-9999}' | tee -a
> > >> > > /var/lib/kafka-#{version}-src/bin/kafka-server-start.sh
> > >> > >
> > >> > >
> > >> > >
> > >> > >
> > >> > >
> > >> > >
> > >> > >
> > >> > >
> > >> > >
> > >> > >
> > >> > >
> > >> > >
> > >> > >
> > >> > > On Fri, Jan 31, 2014 at 4:04 AM, Jay Kreps <[EMAIL PROTECTED]>