Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka, mail # user - Kafka 0.8 on Windows issues


Copy link to this message
-
Re: Kafka 0.8 on Windows issues
Jun Rao 2013-06-28, 06:15
This issue was fixed in kafka-903. The fix is included in the 0.8.0-beta1
release. Do you see the same issue in that version?

Thanks,

Jun
On Thu, Jun 27, 2013 at 9:45 AM, Denny Lee <[EMAIL PROTECTED]> wrote:

> Quick follow up ­ this looks a lot like KAFKA-876
> <https://issues.apache.org/jira/browse/KAFKA-876>  so I'm trying that out
> now.
>
> From:  Denny Lee <[EMAIL PROTECTED]>
> Date:  Thursday, June 27, 2013 9:10 AM
> To:  "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>
> Subject:  Kafka 0.8 on Windows issues
>
> While I was able to spin it up on OSX and Ubuntu without any issues, when
> running this on Windows, I get the following error message when I execute
> the consumer:
> Š
> WARN
>
> [console-consumer-8585_tardis8-1372348635138-29591e5d-leader-finder-thread],
> Failed to add fetcher for [test,0] to broker id:0,host:10.0.1.10,port:9092
> (kafka.consumer.ConsumerFetcherManager$$anon$1)
> kafka.common.NotLeaderForPartitionException
> Š
>
> The consumer console ends up pushing out a lot of messages to the console
> where there is successful connection, fetching of metadata, the above
> warning, and then shutting down the thread and stopping.  Anyone else run
> into a similar problem and by any chance have a solution?
>
> The steps I had followed were:
> - Grabbed the latest bits from github and ran sbt update, sbt package
> - Updated the %\kafka\bin\windows batch files so that they were pointing to
> the windows folder
> - Executed windows\zookeeper-server-start.bat from the %\kafka\bin folder
> - Executed windows\kafka-server-start.bat and
> windows\kafka-console-producer.bat and they appear to look okay
> - Then ran the windows\kafka-console-consumer.bat and it is apparent it is
> not connecting properly
>
> I've tried running this on Windows 8, Windows 2008 R2, and Windows 2012 as
> well as tried using a standalone zookeeper 3.4.5 but with no luck.
>
> Any ideas?  Thanks in advance!
>
>
>