Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Kafka >> mail # user >> compiling with 2.10


+
Kane Kane 2013-11-01, 23:15
+
Jun Rao 2013-11-02, 03:44
+
Kane Kane 2013-11-02, 04:37
+
Ngu, Bob 2013-11-04, 17:48
+
Jun Rao 2013-11-05, 05:41
+
Kane Kane 2013-11-05, 05:54
Copy link to this message
-
Re: compiling with 2.10
Kane,

Would you mind attaching a patch to
https://issues.apache.org/jira/browse/KAFKA-1116 to enable cross
compilation to scala 2.10.2?

Thanks,

Jun
On Mon, Nov 4, 2013 at 9:53 PM, Kane Kane <[EMAIL PROTECTED]> wrote:

> I'm using it with scala 2.10.2.
>
> On Mon, Nov 4, 2013 at 9:41 PM, Jun Rao <[EMAIL PROTECTED]> wrote:
> > Do you think our cross compilation can be extended to scala 2.10.2?
> >
> > Thanks,
> >
> > Jun
> >
> >
> > On Mon, Nov 4, 2013 at 9:48 AM, Ngu, Bob <[EMAIL PROTECTED]> wrote:
> >
> >> Thanks, Kane I had the same problem with assembly-package-dependency and
> >> this fixes it.
> >>
> >> Jun, will scalaVersion be changed to 2.10.x? Currently it¹s set to 2.8.0
> >> and crossScalaVersions includes 2.10.1 but I believe that¹s to publish
> to
> >> local ivy repo but I publish to local maven repo and I need to set
> >> scalaVersion 2.10.2. Thoughts?
> >>
> >> Bob
> >>
> >> On 11/1/13, 9:36 PM, "Kane Kane" <[EMAIL PROTECTED]> wrote:
> >>
> >> >Yes, I've had problem, which resolved with updating sbt-assembly. Will
> >> >open a ticket and provide a patch.
> >> >
> >> >On Fri, Nov 1, 2013 at 8:43 PM, Jun Rao <[EMAIL PROTECTED]> wrote:
> >> >> Does the problem exist with trunk? If so, could you open a jira and
> >> >>submit
> >> >> a patch?
> >> >>
> >> >> Thanks,
> >> >>
> >> >> Jun
> >> >>
> >> >>
> >> >> On Fri, Nov 1, 2013 at 4:14 PM, Kane Kane <[EMAIL PROTECTED]>
> >> wrote:
> >> >>
> >> >>> I think
> >> >>> addSbtPlugin("com.eed3si9n" % "sbt-assembly" % "0.8.8")
> >> >>>
> >> >>> Should be updated to 0.9.0 at least to successfully compile. I've
> had
> >> >>> an issue with assembly-package-dependency.
> >> >>>
> >>
> >>
>

 
+
Ngu, Bob 2013-11-05, 19:00
+
Kane Kane 2013-11-05, 19:03
+
Joe Stein 2013-11-05, 19:05
+
Ngu, Bob 2013-11-05, 21:14
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB