Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka, mail # user - Roadmap


Copy link to this message
-
Re: Roadmap
Joe Stein 2013-10-31, 18:03
A build with Scala 2.10 is published in the 0.8.0 release so you should use
that once released.

/*******************************************
 Joe Stein
 Founder, Principal Consultant
 Big Data Open Source Security LLC
 http://www.stealth.ly
 Twitter: @allthingshadoop <http://www.twitter.com/allthingshadoop>
********************************************/
On Thu, Oct 31, 2013 at 1:58 PM, Richard Rodseth <[EMAIL PROTECTED]> wrote:

> That helped :) I also had to add Log4J and Metrics, but I was then able to
> send a message to the broker.
>
> I'm revealing my Maven ignorance, but I'm unclear why I needed to add
> transitive dependencies.
> Also, since I will be writing Scala 2.10 as well as Java, I presume I will
> need the com.sksamuel.kafka<
> http://search.maven.org/#search%7Cga%7C1%7Cg%3A%22com.sksamuel.kafka%22>
>  artifact.
>
> Thanks. I look forward to trying the official 0.8 release.
>
>
>
> On Thu, Oct 31, 2013 at 9:53 AM, Joe Stein <[EMAIL PROTECTED]> wrote:
>
> > Do you have Scala as a dependency in your pom?
> >
> > <dependency>
> >   <groupId>org.scala-lang</groupId>
> >   <artifactId>scala-library</artifactId>
> >   <version>2.8.0</version>
> > </dependency>
> >
> >
> > /*******************************************
> >  Joe Stein
> >  Founder, Principal Consultant
> >  Big Data Open Source Security LLC
> >  http://www.stealth.ly
> >  Twitter: @allthingshadoop <http://www.twitter.com/allthingshadoop>
> > ********************************************/
> >
> >
> > On Thu, Oct 31, 2013 at 12:48 PM, Richard Rodseth <[EMAIL PROTECTED]
> > >wrote:
> >
> > > Thanks Neha.
> > >
> > > I get the following compilation error in Eclipse, and in a maven build.
> > >
> > > The type scala.collection.Seq cannot be resolved. It is indirectly
> > > referenced from required .class files AppTest.java
> > > /kafkaesque/src/test/java/com/gridpoint/kafkaesque line 68 Java Problem
> > >
> > > <dependency>
> > >
> > >     <groupId>org.apache.kafka</groupId>
> > >
> > >     <artifactId>kafka_2.8.0</artifactId>
> > >
> > >     <version>0.8.0-beta1</version>
> > >
> > > </dependency>
> > >
> > >
> > >
> > > On Thu, Oct 31, 2013 at 9:28 AM, Neha Narkhede <
> [EMAIL PROTECTED]
> > > >wrote:
> > >
> > > > 0.8 release is in progress and Joe Stein can give an update on when.
> > What
> > > > Maven dependency issues did you run into? Some of us have started
> > working
> > > > on 0.9 and the earliest likely release data is probably end of Jan
> > 2014.
> > > I
> > > > updated the versions page to reflect that.
> > > >
> > > > Thanks,
> > > > Neha
> > > >
> > > >
> > > > On Wed, Oct 30, 2013 at 6:39 PM, Richard Rodseth <[EMAIL PROTECTED]
> >
> > > > wrote:
> > > >
> > > > > Hi
> > > > >
> > > > > I just started looking at Kafka today. Installing 0.8 Beta 1 went
> > well
> > > > and
> > > > > I was able to run the command-line producer and consumer. When I
> > tried
> > > to
> > > > > write some Java code, I ran into problems with Maven dependencies
> (it
> > > was
> > > > > looking for Scala.Product). I used the appropriate <dependency>
> from
> > > > Maven
> > > > > central.
> > > > >
> > > > > Looking at the roadmap, 0.8 seems imminent, but no date is listed.
> > 0.9
> > > > has
> > > > > open issues but is listed as due tomorrow.
> > > > >
> > > > >
> > > > >
> > > >
> > >
> >
> https://issues.apache.org/jira/browse/KAFKA?selectedTab=com.atlassian.jira.plugin.system.project%3Aroadmap-panel
> > > > >
> > > > > What's the latest news, and will 0.8 resolve this issue?
> > > > >
> > > > > Thanks! I'm excited about giving it a whirl.
> > > > >
> > > >
> > >
> >
>