Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka >> mail # dev >> Re: Review Request 17688: API refactoring for new producer


Copy link to this message
-
Re: Review Request 17688: API refactoring for new producer

This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17688/#review33556

Ship it!

clients/src/main/java/kafka/clients/producer/Callback.java
<https://reviews.apache.org/r/17688/#comment63077>

    I think Jun suggested this and I agree. We have a callback on the producer, one on the controller and possibly another one on the consumer. How do you feel about renaming this to something that will make it clear that it belongs to the producer, eg ProducerCallback?

clients/src/main/java/kafka/clients/producer/internals/Partitioner.java
<https://reviews.apache.org/r/17688/#comment63078>

    
- Neha Narkhede
On Feb. 4, 2014, 1:41 a.m., Jay Kreps wrote: