Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka >> mail # dev >> [jira] [Commented] (KAFKA-981) Unable to pull Kafka binaries with Ivy


Copy link to this message
-
[jira] [Commented] (KAFKA-981) Unable to pull Kafka binaries with Ivy

    [ https://issues.apache.org/jira/browse/KAFKA-981?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13718356#comment-13718356 ]

David Arthur commented on KAFKA-981:
------------------------------------

Bump. We really should get the invalid pom out of Maven Central, it's affecting a lot of people. I'm not 100% sure, but I think once a release has been signed/published it is immutable. We probably need to delete beta1 and create beta2

Thoughts?
                
> Unable to pull Kafka binaries with Ivy
> --------------------------------------
>
>                 Key: KAFKA-981
>                 URL: https://issues.apache.org/jira/browse/KAFKA-981
>             Project: Kafka
>          Issue Type: Bug
>          Components: packaging
>    Affects Versions: 0.8
>            Reporter: David Arthur
>            Assignee: Joe Stein
>         Attachments: ant.log, ivy.xml
>
>
> I am trying to pull the published Kafka binary with a simple Ivy file.
> <dependency org="org.apache.kafka" name="kafka_2.9.2" rev="0.8.0-beta1" conf="default->default"/>
> I get the following exception: [ivy:resolve] problem occurred while resolving dependency: org.apache.kafka#kafka_2.9.2;0.8.0-beta1 {default=[default]} with main: java.lang.IllegalArgumentException: null name not allowed

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira