Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka, mail # dev - [jira] [Commented] (KAFKA-648) Use uniform convention for naming properties keys


Copy link to this message
-
[jira] [Commented] (KAFKA-648) Use uniform convention for naming properties keys
"Jun Rao 2013-01-08, 02:34

    [ https://issues.apache.org/jira/browse/KAFKA-648?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13546541#comment-13546541 ]

Jun Rao commented on KAFKA-648:
-------------------------------

Thanks for patch v2. I missed a few items in the previous review. Sorry about that. The following are some more comments.

20. We need to standardize properties in ZKConfig too.

21. KafkaConfig: The following names are pretty long.
      replica.fetch.max.wait.time.ms
      replica.fetch.min.expected.bytes
  Would it be better to change them to
      replica.fetch.max.wait.ms
      replica.fetch.min.bytes

22. config/producer.properties: The following properties no longer exist.
# the callback handler for one or multiple events
#callback.handler=

# properties required to initialize the callback handler
#callback.handler.props=

# the handler for events
#event.handler=

# properties required to initialize the event handler
#event.handler.props=

23. config/server.properties: The following property no longer exists.
# Overrides for for the default given by num.partitions on a per-topic basis
#topic.partition.count.map=topic1:3, topic2:4

                
> Use uniform convention for naming properties keys
> --------------------------------------------------
>
>                 Key: KAFKA-648
>                 URL: https://issues.apache.org/jira/browse/KAFKA-648
>             Project: Kafka
>          Issue Type: Bug
>    Affects Versions: 0.8
>            Reporter: Swapnil Ghike
>            Assignee: Sriram Subramanian
>            Priority: Blocker
>             Fix For: 0.8, 0.8.1
>
>         Attachments: configchanges-1.patch, configchanges-v2.patch
>
>
> Currently, the convention that we seem to use to get a property value in *Config is as follows:
> val configVal = property.getType("config.val", ...) // dot is used to separate two words in the key and the first letter of second word is capitalized in configVal.
> We should use similar convention for groupId, consumerId, clientId, correlationId.
> This change will probably be backward non-compatible.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira