Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka >> mail # dev >> [jira] [Commented] (KAFKA-826) Make Kafka 0.8 depend on metrics 2.2.0 instead of 3.x


Copy link to this message
-
[jira] [Commented] (KAFKA-826) Make Kafka 0.8 depend on metrics 2.2.0 instead of 3.x

    [ https://issues.apache.org/jira/browse/KAFKA-826?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13617539#comment-13617539 ]

Scott Carey commented on KAFKA-826:
-----------------------------------

The only real trouble with 3.0.x is if:
* it conflicts with 2.2.x if in the same classloader
* there is no released artifact in a public maven repo to provide repeatable builds.

We might be able to find out when a 3.0-alpha may be available and pushed to a public maven repo.  It does  not appear that a final version is due out in time.

                
> Make Kafka 0.8 depend on metrics 2.2.0 instead of 3.x
> -----------------------------------------------------
>
>                 Key: KAFKA-826
>                 URL: https://issues.apache.org/jira/browse/KAFKA-826
>             Project: Kafka
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 0.8
>            Reporter: Neha Narkhede
>            Assignee: Jun Rao
>            Priority: Blocker
>              Labels: build, kafka-0.8, metrics
>
> In order to mavenize Kafka 0.8, we have to depend on metrics 2.2.0 since metrics 3.x is a huge change as well as not an officially supported release.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira