Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Kafka >> mail # dev >> [jira] [Commented] (KAFKA-854) Upgrade dependencies for 0.8


+
Dragos Manolescu 2013-04-05, 22:49
Copy link to this message
-
[jira] [Commented] (KAFKA-854) Upgrade dependencies for 0.8

    [ https://issues.apache.org/jira/browse/KAFKA-854?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13625652#comment-13625652 ]

Scott Carey commented on KAFKA-854:
-----------------------------------

{quote}
While you're at it you could also upgrade Jackson. Currently the build file references org.codehaus.jackson which is old. The upgrade may require some code changes (the API differs in a few places), all trivial through.
{quote}

Where is the Jackson dependency specified?

find . -name *.sbt | xargs grep jackson

returns nothing, and in project/Build.scala it is only used in relation to the hadoop settings.  We could upgrade to the latest 1.x but not 2.x, because other hadoop dependencies use it (like the also ancient avro 1.4).

What is the status of the contrib hadoop stuff?
Matt's patch already upgrades everything, if we want to upgrade only the core Kafka dependencies, we can trim it down to those simpler, safer updates.  

(As an SBT newbie) --
 It appears that project/Build.scala is completely unnecessary, and could be significantly simplified if moved to core/build.sbt.  Most of the content of Build.scala seems to be cruft or have simpler features available to do the same thing.
                
> Upgrade dependencies for 0.8
> ----------------------------
>
>                 Key: KAFKA-854
>                 URL: https://issues.apache.org/jira/browse/KAFKA-854
>             Project: Kafka
>          Issue Type: Improvement
>    Affects Versions: 0.8
>            Reporter: Scott Carey
>         Attachments: 0001-KAFKA-854-Upgrade-Deps-to-latest.patch
>
>
> Many of the dependencies that Kafka 0.8 uses are old.  It would be a good idea to upgrade all of these where possible.
> log4j is set to 1.2.15, but the latest is 1.2.17
> zookeeper is at 3.3.4, , there is 3.3.6 (August 2012), and 3.4.5 (Nov 2012.  3.4.x  includes several major enhancements and fixes over the 3.3.x line.
> org.slf4j is at 1.6.4, there is 1.6.6 (June 2012) and 1.7.5 (March 2013)
> net.sf.jopt-simple is at 3.2, there is 3.3 (May 2011) and 4.4 (Jan 2013)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

 
+
Neha Narkhede 2013-04-09, 23:18
+
Matt Christiansen 2013-04-13, 00:00
+
Scott Carey 2013-04-12, 20:22