Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase, mail # user - run mvn error


+
Weishung Chung 2011-04-29, 15:51
+
Stack 2011-04-29, 16:28
+
Weishung Chung 2011-04-29, 19:56
+
Weishung Chung 2011-05-03, 15:58
+
Ted Yu 2011-05-03, 16:16
Copy link to this message
-
Re: run mvn error
Weishung Chung 2011-05-03, 16:34
Thank you...running the build now :)

On Tue, May 3, 2011 at 11:16 AM, Ted Yu <[EMAIL PROTECTED]> wrote:

> Test cases aren't dependent on physical hbase cluster.
>
> On Tue, May 3, 2011 at 8:58 AM, Weishung Chung <[EMAIL PROTECTED]> wrote:
>
> > I haven't found a fix. But, in the saveVersion.sh, I enter the user name
> > directly to get it going.
> > For all the test cases, do I need to have hbase up and running?
> >
> > On Fri, Apr 29, 2011 at 2:56 PM, Weishung Chung <[EMAIL PROTECTED]>
> > wrote:
> >
> > > It is the path separator, "\", I guess it can't handle the windows path
> > > separator. Ok. I will continue to look into this...
> > >
> > > On Fri, Apr 29, 2011 at 11:28 AM, Stack <[EMAIL PROTECTED]> wrote:
> > >
> > >> I don't have a windows machine nearby to try the build on.
> > >>
> > >> It looks like javadoc tool on windows is having problems with content
> > >> of the generated package-info.java file.
> > >>
> > >> Here is what it looks like on linux:
> > >>
> > >> /*
> > >>  * Generated by src/saveVersion.sh
> > >>  */
> > >> @VersionAnnotation(version="0.91.0-SNAPSHOT", revision="1097689",
> > >>                         user="stack", date="Fri Apr 29 09:21:14 PDT
> > >> 2011", url="https://svn.apache.org/repos/asf/hbase/trunk")
> > >> package org.apache.hadoop.hbase;
> > >>
> > >>
> > >> What is in yours?  At line 5, character 40 in mine its 'd'.  Maybe its
> > >> an issue with locale?
> > >>
> > >> The above is created by the build.  See the pom.xml where we run an
> > >> ant exec to run a shell script to generate the above (This is a trick
> > >> picked up from hadoop -- it does the same):
> > >>
> > >>                <exec executable="sh">
> > >>                  <arg line="${basedir}/src/saveVersion.sh
> > >> ${project.version} ${generated.sources}"/>
> > >>                </exec>
> > >>
> > >> Maybe this is being mangled in your windows setup?
> > >>
> > >> If you figure a fix, please add it to an issue.
> > >>
> > >> Yours,
> > >> St.Ack
> > >>
> > >>
> > >>
> > >> On Fri, Apr 29, 2011 at 8:51 AM, Weishung Chung <[EMAIL PROTECTED]>
> > >> wrote:
> > >> > Hello my fellow HBase users,
> > >> >
> > >> > I need your expertise here...
> > >> > I was running
> > >> > mvn clean site install assembly:single
> > >> >
> > >> > and got the following compilation errors on package-info.java
> > >> >
> > >> > [ERROR]
> > >> >
> > >>
> >
> c:\workspace\hbase\target\generated-sources\org\apache\hadoop\hbase\package-info.java:[5,40]
> > >> > illegal escape character
> > >> > [ERROR]
> > >> > [ERROR]
> > >> >
> > >>
> >
> c:\workspace\hbase\target\generated-sources\org\apache\hadoop\hbase\package-info.java:[5,30]
> > >> > unclosed string literal
> > >> > [ERROR]
> > >> > [ERROR]
> > >> >
> > >>
> >
> c:\workspace\hbase\target\generated-sources\org\apache\hadoop\hbase\package-info.java:[6,0]
> > >> > class, interface, or enum expected
> > >> > [ERROR]
> > >> > [ERROR]
> > >> >
> > >>
> >
> C:\workspace\hbase\target\generated-sources\org\apache\hadoop\hbase\package-info.java:[6,9]
> > >> > class, interface, or enum expected
> > >> > [ERROR]
> > >> > [ERROR]
> > >> >
> > >>
> >
> C:\workspace\hbase\target\generated-sources\org\apache\hadoop\hbase\package-info.java:[6,45]
> > >> > unclosed string literal
> > >> >
> > >> > Thank you so much,
> > >> > Wei Shung
> > >> >
> > >>
> > >
> > >
> >
>