Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # dev >> VOTE: hbase-0.95.1 release candidate 0 is available for download


Copy link to this message
-
Re: VOTE: hbase-0.95.1 release candidate 1 is available for download
Thanks Elliott,

I was trying something similar that worked in the past, but couldn't make
it work on this last release. I will retry with yours later (my machine is
running a test right now), except if it already worked for you on this
0.95.1 release?

As well, it's good enough for an alpha release, but do know what we will do
for the official one?
IIRC, duplicating the pom.xml was considered as a possible solution?

On Tue, Jun 11, 2013 at 12:48 AM, Elliott Clark <[EMAIL PROTECTED]> wrote:

> So the maven pom's still point to 1.0 as default no matter what version of
> the client you point at.  I've gotten around this by being very explicit:
> <dependencies>
>
>       <dependency>
>           <groupId>org.apache.hbase</groupId>
>           <artifactId>hbase-client</artifactId>
>           <version>${hbase.version}</version>
>
>           <exclusions>
>               <exclusion>
>                   <groupId>org.apache.hadoop</groupId>
>                   <artifactId>hadoop-core</artifactId>
>               </exclusion>
>               <exclusion>
>                   <groupId>org.mortbay.jetty</groupId>
>                   <artifactId>jetty</artifactId>
>               </exclusion>
>               <exclusion>
>                   <groupId>com.sun.jdmk</groupId>
>                   <artifactId>jmxtools</artifactId>
>               </exclusion>
>               <exclusion>
>                   <groupId>com.sun.jmx</groupId>
>                   <artifactId>jmxri</artifactId>
>               </exclusion>
>           </exclusions>
>       </dependency>
>       <dependency>
>           <groupId>org.apache.hadoop</groupId>
>           <artifactId>hadoop-common</artifactId>
>           <version>2.0.0-alpha</version>
>       </dependency>
>   </dependencies>
>
>
> It's not awesome but it got me working.
>
>
>
> On Mon, Jun 10, 2013 at 3:43 PM, Nicolas Liochon <[EMAIL PROTECTED]>
> wrote:
>
> > Hi,
> >
> > I've tried to test the hadoop2 maven release with ycsb.
> >
> > If I build hbase locally, with
> >  mvn clean install -DskipTests -Dhadoop.profile=2.0
> > then I can compile ycsb, providing 0.95.1 as the hbase version.
> > => Compilation & execution works.
> >
> > If I provide 0.95.0-hadoop2-SNAPSHOT (the version found in
> > https://repository.apache.org/content/groups/snapshots/org/apache/hbase,
> > but there is a bunch of files with different dates there)
> >
> > Then it builds, but I have a failure on execution.
> > Caused by: java.lang.NoSuchMethodError:
> >
> >
> org.apache.hadoop.net.NetUtils.getInputStream(Ljava/net/Socket;)Ljava/io/InputStream;
> >         at
> >
> >
> org.apache.hadoop.hbase.ipc.RpcClient$Connection.setupIOstreams(RpcClient.java:814)
> >
> > When I dig with mvn dependency:tree, I see hadoop2 dependencies only, as
> > expected.
> >
> > => Is that the version to use? If not, which one should I use, from which
> > repo?
> >
> >
> > As well, by default, we don't configure log4j, so we don't have anything
> on
> > screen: log4j does not output to screen by default for security reasons
> (if
> > the data is confidential). We should probably change this.
> >
> > Cheers,
> >
> > Nicolas
> >
> >
> >
> >
> >
> >
> >
> > On Fri, Jun 7, 2013 at 12:37 AM, Stack <[EMAIL PROTECTED]> wrote:
> >
> > > Here is our second 0.95.1 release candidate.  Should we put this out as
> > > 0.95.1?
> > >
> > > Since 0.95.1 is "just" a "Development" Series release [1], lets keep
> the
> > > vote period short.  Please vote by this Tuesday, June 11th.
> > >
> > > The release artifacts may be downloaded from:
> > >
> > >   http://people.apache.org/~stack/hbase-0.95.1RC1/<
> > > http://people.apache.org/~stack/hbase-0.95.1RC0/>
> > >
> > > Almost 200 issues have been closed since we put out 0.95.0 [2].
> > >
> > > All feedback is welcome.  We'd be interested in getting comments on
> > > everything from the packaging, layout, through documentation, UI, and
> of
> > > course,
> > > any bugs found.  I deployed SNAPSHOTs to maven and would particularly
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB