Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HDFS, mail # user - Re: New to Hadoop-SSH communication


+
Mohammad Tariq 2013-04-30, 21:14
+
Automation Me 2013-04-30, 21:30
+
Mitra Kaseebhotla 2013-04-30, 21:42
Copy link to this message
-
Re: New to Hadoop-SSH communication
Automation Me 2013-04-30, 21:52
@Mitra Yes I cloned the same VM's. By default Ubuntu takes 127.0.0.1
-ubuntu hostname for all machines

@Tariq i will send the hosts file and users of all the machines.
On Tue, Apr 30, 2013 at 5:42 PM, Mitra Kaseebhotla <
[EMAIL PROTECTED]> wrote:

> Looks like you have just cloned/copied the same VMs. Change the hostname
> of each:
>
> http://askubuntu.com/questions/87665/how-do-i-change-the-hostname-without-a-restart
>
>
>
> On Tue, Apr 30, 2013 at 2:30 PM, Automation Me <[EMAIL PROTECTED]>wrote:
>
>> Thank you Tariq.
>>
>> I am using  the same username on both the machines and when i try to copy
>> a file master to slave just to make sure SSH is working fine, The file is
>> copying into master itself not an slave machine.
>>
>>   scp -r /usr/local/somefile hduser@slave:/usr/local/somefile
>>
>> Any suggestions...
>>
>>
>> Thanks
>> Annt
>>
>>
>>
>> On Tue, Apr 30, 2013 at 5:14 PM, Mohammad Tariq <[EMAIL PROTECTED]>wrote:
>>
>>> ssh is actually *user@some_machine *to *user@some_other_machine*.
>>> either use same username on both the machines or add the IPs along with
>>> proper user@hostname in /etc/hosts file.
>>>
>>> HTH
>>>
>>> Warm Regards,
>>> Tariq
>>> https://mtariq.jux.com/
>>> cloudfront.blogspot.com
>>>
>>>
>>> On Wed, May 1, 2013 at 2:39 AM, Automation Me <[EMAIL PROTECTED]>wrote:
>>>
>>>> Hello,
>>>>
>>>> I am new to Hadoop and trying to install multinode cluster on ubuntu
>>>> VM's.I am not able to communicate between two clusters using SSH.
>>>>
>>>> My host file:
>>>>
>>>> 127.0.1.1 Master
>>>> 127.0.1.2 Slave
>>>>
>>>> The following changes i made in two VM's
>>>>
>>>> 1.Updated the etc/hosts file in two vm's
>>>>
>>>> on Master VM
>>>>  i did SSH keygen and trying to copy the key into Slave
>>>>
>>>> ssh-keygen -t rsa -P ""
>>>>        cat $HOME/.ssh/id_rsa.pub >> $HOME/.ssh/authorized_keys
>>>>        ssh-copy-id -i $HOME/.ssh/id_rsa.pub slave@ubuntu.
>>>>
>>>> When i login into master and slave  and check
>>>>
>>>> master@ubuntu>Hostname it says UBUNTU
>>>> slave@ubuntu>Hostname it says UBUNTU
>>>>
>>>>
>>>> Could you assist me on this?
>>>>
>>>> Thanks
>>>> Annt
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>
>
>
> --
>  ________________________________________
>
>  To Understand Recursion,
>  You must first Understand Recursion
>  ________________________________________
>
+
Mohammad Tariq 2013-04-30, 21:41
+
Mohammad Tariq 2013-04-30, 22:14
+
Automation Me 2013-04-30, 22:18