Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Flume, mail # user - flume-ng agent startup problem


+
Jagadish Bihani 2012-08-08, 07:45
+
alo alt 2012-08-08, 07:49
Copy link to this message
-
Re: flume-ng agent startup problem
Patrick Wendell 2012-08-08, 16:49
Jagadish,

If you use the new page and it still doesn't work, can you send me the
output of jstack against the flume pid? I've noticed some similar issues in
the past (silent startup failures) and I'm also trying to debug.

- Patrick

On Wed, Aug 8, 2012 at 12:49 AM, alo alt <[EMAIL PROTECTED]> wrote:

> HI,
>
> This page is outdated. Please follow:
> http://flume.apache.org/FlumeUserGuide.html#setup
>
> Since you haven't attached logs or error messages it's hard to say what
> happen.
>
> best
> - Alex
>
>
> Jagadish Bihani wrote:
>
>
> Hi
>
> I have downloaded the tarball of latest flume-ng 1.2.0.
> I have JAVA_HOME properly set.
>
> To begin with I have followed the instructions in "
> https://cwiki.apache.org/FLUME/getting-started.html"
> as it is. And even for that basic example:
>
> My flume agent stucks printing the following output and then nothing
> happens:
>
> *bin/flume-ng agent --conf ./conf/ -f conf/flume.conf -n agent1
>
> + exec /usr/java/jdk1.6.0_12/bin/java -Xmx20m -cp
> '/root/flume/apache-flume-1.2.0/conf:/root/flume/apache-flume-1.2.0/lib/*'
> -Djava.library.path= org.apache.flume.node.Application -f
> conf/flume.conf -n agent1*
>
>
> Please guide me what might be the cause.
>
> Regards,
> Jagadish
>
>
>
>   Jagadish Bihani <[EMAIL PROTECTED]>
>  August 8, 2012 9:45 AM
>  Hi
>
> I have downloaded the tarball of latest flume-ng 1.2.0.
> I have JAVA_HOME properly set.
>
> To begin with I have followed the instructions in "
> https://cwiki.apache.org/FLUME/getting-started.html"
> as it is. And even for that basic example:
>
> My flume agent stucks printing the following output and then nothing
> happens:
>
> * bin/flume-ng agent --conf ./conf/ -f conf/flume.conf -n agent1
> + exec /usr/java/jdk1.6.0_12/bin/java -Xmx20m -cp
> '/root/flume/apache-flume-1.2.0/conf:/root/flume/apache-flume-1.2.0/lib/*'
> -Djava.library.path= org.apache.flume.node.Application -f conf/flume.conf
> -n agent1*
>
> Please guide me what might be the cause.
>
> Regards,
> Jagadish
>
>
> --
> Alexander Alten-Lorenz
> http://mapredit.blogspot.com
> German Hadoop LinkedIn Group: http://goo.gl/N8pCF
>
+
Hari Shreedharan 2012-08-08, 16:57
+
Jagadish Bihani 2012-08-10, 10:00
+
Jagadish Bihani 2012-08-11, 09:09
+
Patrick Wendell 2012-08-11, 20:49
+
Jagadish Bihani 2012-08-14, 13:11
+
ashutosh 2012-08-09, 08:48
+
Hari Shreedharan 2012-08-10, 17:07