Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Zookeeper >> mail # user >> Staggered start of nodes in an ensemble


Copy link to this message
-
Re: Staggered start of nodes in an ensemble
can you provide the configurations (zoo.cfg) on each server. From the
description, your server 1 seems to be incorrectly configured.

thanks,
Kishore G
On Mon, Nov 11, 2013 at 8:19 AM, Arindam Mukherjee <
[EMAIL PROTECTED]> wrote:

> Of late I have been bombarding this list with questions and am getting
> a little frustrated at my lack of understanding of ZooKeeper. I am up
> against deadlines that look infeasible now. :(
>
> Anyway, having majorly failed to get going with 3.5.0 (you might see a
> question earlier today), I decided, for the purposes of a PoC to
> create a static 3.4.6 configuration. Say, create max 3 VMs, of which 2
> are always up. Initially 1 and 2 would be up. I would be listing 3
> servers in the config - server.1 through server.3.
>
> I brought up the servers on 1 and 2 in that order using "zkServer.sh
> start-foreground". However they failed to connect and form a quorum
> and the foreground server process showed an increasing timeout. Then I
> brought up 3 at which point 2 and 3 were able to connect.
>
> Next I started zkCli.sh from 1 - it failed to connect to any box.
> However the ones on 2 and 3 connected neatly. I am at a little loss to
> explain this. Need help.
>
> Thanks.
> Arindam
>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB