Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Zookeeper >> mail # dev >> 3.4 blocker? rename MultiTransactionRecord to MultiRequest


Copy link to this message
-
3.4 blocker? rename MultiTransactionRecord to MultiRequest
Hi,

I've opened ZK-1257 with this description:

<quote>
Understanding the code behind multi operations doesn't get any easier when the
code violates naming consistency.
All other Request classes are called xxxRequest, only for multi its
xxxTransactionRecord! Also "Transaction" is wrong, because there is the
concepts of transactions that are transmitted between quorum peers or
committed to disc. MultiTransactionRecord however is a Request from a client.
</quote>

I think the rename could also happen after 3.4 since MultiTransactionRecord is
not part of the API? If not, I strongly recommend to do the rename before the
release.

Regards,

Thomas Koch, http://www.koch.ro