Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Sqoop, mail # user - Possible bug (export) --direct and --input-fields-terminated-by '\t' not working correctly?


Copy link to this message
-
RE: Possible bug (export) --direct and --input-fields-terminated-by '\t' not working correctly?
Connell, Chuck 2012-07-26, 23:41
Thanks Kathleen,

I read that report and I think mine is different. I do not get an error message, but the export yields the wrong result. I will file a jira.

Chuck
________________________________________
From: Kathleen Ting [[EMAIL PROTECTED]]
Sent: Thursday, July 26, 2012 6:01 PM
To: [EMAIL PROTECTED]
Subject: Re: Possible bug (export) --direct and --input-fields-terminated-by '\t' not working correctly?

Chuck,

I think you might be hitting
https://issues.apache.org/jira/browse/SQOOP-450, fixed in upcoming
release Sqoop 1.4.2

Regards, Kathleen

On Thu, Jul 26, 2012 at 6:46 AM, Connell, Chuck
<[EMAIL PROTECTED]> wrote:
> I have a Hive table that has tab-separated fields. I am exporting it to MySQL. The export works fine (using --input-fields-terminated-by '\t') and I get correct results in MySQL.
>
> BUT, when I add the --direct option, the export fails. The source file (in Hive warehouse) is not parsed correctly and the tabs are ignored. The fields are not separated correctly when placed into MySQL.
>
> Anyone else run into this?
>
> Chuck Connell
> Nuance R&D Data Team
> Burlington, MA
>